Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I attempted to do a dual boot install of Ubuntu 12.04 LTS alongside Windows Vista. I tried the traditional liveusb install method, but the installer ran into an error while attempting to partition the hard disk. I aborted the install and rebooted into Windows. From there, I downloaded the Wubi installer and started an install on the C: drive (no other partitions available).

The install seemed to work alright, and rebooting the first time into ubuntu worked alright. I rebooted once more to get back into Windows, and after the loading of Windows, I get an error that states the following: "Loginui.exe error, c:\windows\system32\xmllite.dll is not designed to run on windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support." I then let windows to a disk check and attempt a startup repair, but neither works.

I try to log into Ubuntu, and after selecting Ubuntu on startup I get a GRUB Bash session instead of loading ubuntu.

At this point I have tried everything I could find except doing a factory reset of windows, because I would rather not have to pay for Microsoft Office again. I have done multiple attempts of startup repair, resulting in "Startup Repair could not find any problems". I have used the recovery tools to run sfc /scannow, dskchk, and check registry entries for errors.

Through using a liveusb run of Ubuntu, I have replaced the bad file xmllite.dll with a good one downloaded from http://www.dll-files.com/dllindex/dll-files.shtml?xmllite. This removes the error, but Vista still hangs on the black screen. Ctrl-Alt-Del does nothing, neither does Ctrl-Shift-Esc.

My priority is to have Vista running again ASAP, and I am in the process of copying all user files to an external through a liveusb session. Please help if you have any ideas of what the problem is and what's going on.

share|improve this question
1  
I finally broke down and did a fresh reinstall of Windows after accessing and backing up files via a liveusb session. I spoke to some knowledgeable friends, and they said the problem was most likely due to the error while partitioning, and that a reinstall would be best. –  Lukas Woltjer Sep 24 '12 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.