Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some time ago I accidentally dded ISO to my hard drive. After that I've reinstalled OS, but my Arch installation still recognize extended partition as ISO file and display it in Nautilus:

Drives screenshot

When I try to mount it I've got:

Error mounting /dev/sda4 at /run/media/hauleth/Linux Mint Debian 64-bit:
Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,
gid=1000,iocharset=utf8,mode=0400,dmode=0500" "/dev/sda4"
"/run/media/hauleth/Linux Mint Debian 64-bit"' exited with non-zero
exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I had this once with a USB-Stick. The beginning of the hard drive or partition you dded the ISO to now has the beginning of the ISO as startblock. It may happen that this is not overwritten when creating a new filesystem or partition table. As to my knowledge this problem can't be resolved without loss of data. I solved it by overwriting the USB-Stick with zeros from /dev/zero and recreating the partition table.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.