Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a TP-Link 740N v3 router with WAN port and LAN port 1 burned.

I was able to flash DD-WRT and to apparently configure WAN port to LAN port 4 (or 1, I don't actually know how are they numbered by kernel).

Laptop on Wi-fi receives a correct address, from 192.168.1.* network.

But PC, on a wire, receives an IP address from 37.* (for example) network. After that, routing from Internet to Wi-fi 192.168.1.* network stops. When PC is off, Internet appears on 192.168.1.* again. Apparently, PC grabs an external IP and "all the Internel" from WAN.

Is there anything except vlan1ports/vlan0ports I should configure?

Some diagnostics, ipconfig and so: https://gist.github.com/92899e26d2e35897714c

What else do I need to change to get port 4 to be WAN and wired ports 2-3 to be LAN (onto 192.168.1.* network)?

edit:

Apparently I need to add another VLAN for local Ethernet ports, other then the "new WAN" (port #4). That's because PC gets an IP over Ethernet directly from WAN, and I need PC to be on LAN (192.*) network.

But my router doesn't have a VLAN admin GUI, though it's of the same version - v24 preSP2.

I followed all the instructions to separate Ethernet ports into different VLANs, and still no luck, PC still grabs an IP from my ISP as if the router was a simple switch.

share|improve this question
    
See this link for how to understand port numbers. The entire article has step-by-step procedure of replacing the uplink port. –  bytebuster Sep 25 '12 at 12:24
    
I did follow it, as you can see from nvram show output. Something still went wrong. Do you know what it was? –  Victor Sergienko Sep 25 '12 at 13:22

1 Answer 1

up vote 0 down vote accepted

Sounds like you haven't configured the LAN ports correctly yet. The ports are still acting like a hub and not like a firewall; hence the PC grabbing the external IP. As far as I know the areas to look into are VLAN(which you're already doing) and global router settings(like if it's a bridge, gateway or router).

Have you tried again with the latest firmware?

share|improve this answer
    
I cannot try the latest firmware - I don't have that router any longer. I believe you're correct about the gateway/router setting. –  Victor Sergienko Aug 4 '13 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.