Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have links to secure sites inside Excel spreadsheets (currently 2010, but I'm pretty sure it's the same with Office 2007).

When I click on them, instead of just launching the system browser (Firefox), and seeing the password prompt from the browser - it seems that Office tries to connect to the site itself. So I see a certificate warning and then a Windows Security password prompt.

After that, if I get the user/password correct, it will open the browser which then prompts me again.

This is annoying and insecure (Windows/Office shouldn't need that password)

Why does Office do this and how do I stop it?

share|improve this question
    
This might help : support.microsoft.com/kb/218153/en-us –  BrianAdkins Sep 24 '12 at 2:54

2 Answers 2

It seems the answer is that, for Office 2010, the relevant value is no longer under the Wow6432Node. Now, it has to be set under the original location

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet\
ForceShellExecute = 1

I had actually tried that before, but incorrectly read the first part of the article that says the "Internet key" should be set to 1.

This implies that Office 2010 (or at least, Excel 2010, which I tested with) is now somewhat a 64 bit application.

share|improve this answer
    
Oh, d'oh. I installed the 64 bit version of Office 2010. –  O'Rooney Feb 27 '13 at 23:21

Excel does some strange stuff with links.. Especially if your default browser is not IE.

Looks like there are some registry settings you can play with to force a browser to open:

http://support.microsoft.com/kb/218153/en-us

share|improve this answer
    
Great find! So far, I have not managed to get this working. The kb article is specific that it won't be different for different versions of Office, I tried the setting under Office\14.0 (for 2010) anyway... maybe it needs a Windows restart though that seems unlikely... –  O'Rooney Sep 25 '12 at 0:31
    
Ah, I seem to have got it working. –  O'Rooney Feb 3 '13 at 21:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.