Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, I switched from initscript to systemd followed this wiki, and I got error like this during boot:

Job dev-md126p5.device/start timed out

This is my fstab:

/dev/mapper/VGLinux-lvroot / ext4 rw,relatime,stripe=64,data=ordered 0 1
/dev/mapper/VGLinux-lvhome /home ext4 rw,relatime,stripe=64,data=ordered 0 2
/swapfile none swap defaults 0 0
/dev/md126p5 /media/data ntfs-3g uid=xiaoxing,gid=users 0 0

Here is my partition scheme: I have two hard drives which are identical and as default, it is a raid0. Three partitions like this:

1. windows 7, 200GB, ntfs
2. linux, 100GB, lvm
  / , 30GB, ext4
  /home , 30GB, ext4
  the rest for future expend.
3. data, rest, ntfs

After the "timed out", it throws me into an emergency mode, I can mount the data partition manually, and run "systemctl default", it will start the system properly. Or I can comment out the "data" part in the fstab file, and get into the system and mount it easily.

There is no problem before I switched to systemd. Now I've tried everything including write my own .service file to mount it, but it still can not mount the partition during boot. Any ideas?

share|improve this question

migrated from stackoverflow.com Sep 24 '12 at 0:46

This question came from our site for professional and enthusiast programmers.

    
Try asking this on super user - you'll get better answers there. –  Linuxios Sep 22 '12 at 14:45
    
Thanks a lot, that's a good idea! –  dawnstar Sep 23 '12 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.