Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to run an app on my mac but it quickly closes, I've checked the Quarantine flag but that was not the problem, I checked Console and here's the error information:

9/24/12 1:44:19.343 AM com.apple.launchd.peruser.501[150]: ([0x0-0x330330].com.krill.CodeRunner[5405]) Job failed to exec(3) for weird reason: 13

How can I fix this?

Thanks in advance

share|improve this question

migrated from stackoverflow.com Sep 24 '12 at 2:47

This question came from our site for professional and enthusiast programmers.

2  
errno 13 would be EACCESS (permission denied). – lanzz Sep 23 '12 at 22:30
    
thank you so much :) I tried chmod +x and it worked. – Shahin Sep 23 '12 at 22:34
    
@lanzz do you have a link for the source of the errno explanation? – stib Mar 13 '14 at 5:22
1  
unix.com/man-page/freebsd/2/errno – lanzz Mar 14 '14 at 9:08
up vote 20 down vote accepted

Thanks to lanzz

I found out that the problem is permissions.

I used chmod +x to set the executable app under MacOS folder of the .app to make it executable and the problem is fixed.

share|improve this answer
1  
This worked beautifully. I also ran into this issue with Minecraft and Slender: The Eight Pages. using chmod u+x <Application.app>/Contents/MacOS/<application binary> fixed the problem in both cases. – spex Feb 21 '13 at 21:04

If chmod doesn't work for you:

I was getting the same error with an .app file extracted from a zip but the chmod solution didn't help. I eventually found this page which suggested re-extracting the file from the original zip using the Archive Utility. This worked for my case.

(I had extracted it using 7-Zip on a PC and picked it up on the Mac via DropBox which presumably mangled the permissions in some manner.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .