Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop has both USB 2.0 and 3.0 ports. I've connected:

  • mouse -- USB 2.0 port
  • keyboard -- USB 3.0 port

On starting the system, the mouse is active however the keyboard does not function. Everytime i have to disconnect the keyboard and plug it back in and only then it becomes active.

Is there any fix to this problem or is the USB port itself faulty?

specs: Dell XPS, 64-bit i7 processor with 8G of RAM

share|improve this question
    
What operating system? Do you dual-boot? Do you have a liveCD or live USB drive available to boot into? –  zero2cx Sep 24 '12 at 4:57
    
Windows 7 64 bit. No dual boot, just the one OS. I'm not sure about liveCD, how would it help? –  Jay Sep 24 '12 at 5:09
    
It would really only help in the Linux realm. Log files and differing Linux distros could reveal a lot to see what's going on. But not really for Windows. –  zero2cx Sep 24 '12 at 6:42
    
Does it work (without reconnecting) before you boot into an OS? In other words, can you use it on the startup/BIOS screen? Does the mouse or the keyboard exhibit the same problem if you swap the ports? –  Bob Sep 24 '12 at 8:35
    
@Bob No it doesn't work on the BIOS screen as well. I also tried connecting both the mouse and keyboard to a USB hub and then the hub to the port - both keyboard and mouse stop working. :( –  Jay Sep 24 '12 at 9:02
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.