Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My current work enviroment is Windows workstation with Putty. And almost always i run "screen" session. When i started using CentOS 6 i noticed strange behavior with screen. When I run screen in Putty ssh session the size of window (terminal) is reseted (rows and cols were changed). For me this is very anoying and i'm unable to resolve this. Maybe someone know what to change in Putty config or terminal settings (termcap/termininfo or screenrc) to stop this behavior? I hope someone understand me. English is not my best side...

share|improve this question

migrated from serverfault.com Sep 24 '12 at 11:28

This question came from our site for professional system and network administrators.

1 Answer 1

up vote 3 down vote accepted

According to a bunch of links from a quick Google Search, one of these solutions should work:

  • A: Add this line to your ~/.screenrc or /etc/screenrc:

    termcapinfo xterm* 'is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l'
    
  • B: Always run screen with the -A option
  • C: Dig arround PuTTY's settings until you find an option to disable remote screen resizing (unlikely)
share|improve this answer
    
Thank you very much for your reply. You make my day :) –  RJS Sep 15 '12 at 7:20
    
FYI, Debian (and therefore Ubuntu) already has the described termcapinfo command in its /etc/screenrc file. RHEL/CentOS does not, because it is commented out (termcap and terminfo commands on line 65; termcapinfo is equivalent to both). –  Alastair Irvine May 23 at 4:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.