Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have bought an sound card - Sound Blaster X-FI Surround 5.1 PRO and while I'm listening to the music, after few minutes or even hours (it does happends randomly) the sound dissapears and I have to go settings: Playing Devices -> Advanced and switch the Default Format (sampling frequency) and switch from the `16-bits, 48000 Hz (DVD Quality) to any other from the list (16-bits, 96000 Hz or 24-bits, 48000 Hz or 24-bits 96000 Hz). I have been trying to set all of the above options, but for all of them the sound freezes after listening to music. It is getting annoying and I hope its the settings fault and not my sound card.

I got my drivers installed from the attached CD and I'm running Windows 7 HP 64 bits. If anyone would try to help me, I would really appreciate this.

share|improve this question
add comment

1 Answer

The first thing I would try is downloading the drivers from the web. The drivers on CD's that come with hardware are usually always out of date, so it's best to download the latest drivers from the manufacturers website.

If the latest drivers don't make a difference I would have to put it down to faulty hardware.

Hope this helps

share|improve this answer
    
Yeh I've downloaded the latest drivers with the auto update app and I think that update did cause that problem... –  Scott Sep 24 '12 at 15:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.