Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

is there a way to fix your windows 7 professional guest host os ipaddress so it does not change every time you startup? I am currently using NAT for networking and would like to remain using this networking method if possible. In older versions of windows this never used to be a problem in vmware so I am wondering if I am missing a setting in windows 7 professional or in vmware.

thank you for your help, chris

share|improve this question

migrated from stackoverflow.com Sep 24 '12 at 15:13

This question came from our site for professional and enthusiast programmers.

    
I'm on VMWare Workstation 6.5.1 and the IP of a Windows 7 prof. guest stays the same after restarts. I'd recommend to check DHCP lease duration in Virtual Network Editor for the NAT virtual host adapter (usually VMNet8). –  Andreas Schuldhaus Dec 13 '10 at 18:06
    
this is a great idea, I am giving that a try now, I expanded the setting to 864000 with a max of 900000 –  chrishough Dec 14 '10 at 15:52

2 Answers 2

I had a similar problem with an Ubuntu guest and couldn't change to a static IP, and fixed using the following:

You can allocate a static lease for behind NAT by adding it here (Win 7, VMWare Player 5):-

C:\Documents and Settings\All Users\Application Data\VMware\vmnetdhcp.conf

host UbuntuVM {
    hardware ethernet 00:0c:29:b7:86:ab;
    fixed-address 192.168.216.99;
}
  • you add it before the final #end
  • you need to change the example 192.168.216 above to your subnet
  • maybe allocate outside of the DHCP pool. I believe this is 123-254 so chose 99
  • you need to edit the security on the file to get permission to save it.
  • stop the vm before and restart the vmware dhcp service after you've saved the change

from: http://communities.vmware.com/thread/341785

share|improve this answer

here is what worked for me: http://blog.mclaughlinsoftware.com/2009/11/26/windows-7-static-ip/

not sure its 100% but so far after 2 reboots its working as expected

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.