Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to disable it on external drives to ensure that the data is really copied/written to the drive, write cache makes it difficult for me to decide whether the data is already copied/written or not.

I tried to issue:

hdparm -W 0 /dev/sdb

but it said:

/dev/sdb:
 setting drive write-caching to 0 (off)
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 write-caching =  1 (on)

So, anyway, it failed to disable the cache.

share|improve this question

migrated from stackoverflow.com Sep 24 '12 at 18:13

This question came from our site for professional and enthusiast programmers.

    
wouldn't that fit more to unix.stackexchange.com? –  Jonas Wielicki Sep 23 '12 at 11:08
    
You might want the sync option to mount and also use the sync command. –  Basile Starynkevitch Sep 23 '12 at 13:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.