Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Skype an other applications running under windows 7 Ultimate are presenting the video captured from the laptop built-in webcam upside down.

I've tried many solution that I was able to find regarding issues like this, but to no avail. Some of the most relevant are discussed here:

Both present several potential solutions to this issue, but I've been unable to fix it for the laptop ASUS U6S.

What I've already tried:

  1. Changing Drivers

    The driver that works must be the one from Windows, all others available from ASUS drivers either don't install or install but the webcam doesn't provide any video feed. This disallows all options that concern using an older driver or editing the .inf file as to manually adjust the settings.

    ASUS does not provide drivers for Windows 7, so I've used drivers from Windows Vista 32 Bit.

  2. Using the application manycam

    This application actually solves the issue (temporarily), but creates new ones:

    • If I use the application to flip the video feed, Skype video call cease to work.
    • This application doesn't save the settings, at least I wasn't able to find any way to save the settings I've used to flip the video feed.

    A computer restart brings all back to how it was, video feed upside down and if the application is still installed, Skype continues to fail on video calls.

  3. Regedit

    I've searched thru Windows Registry Editor as to find any reference to the webcam settings, hopping to find a key with the Flip parameter, since it's up to the driver to flip the image (by what I could ascertain from this problem).

    Couldn't find any reference to such settings, either they actually don't exist within the Windows Registry or they use some weird name that I could think off.

  4. System Configuration

    I was able to access the webcam system settings from the Windows Device Manager, but the tab that actually has the Image Rotation setting is always disabled.

    The same goes for the settings available from the Skype webcam options (that essentially is presenting the same settings as Windows Device Manager, just within a custom Skype pop-up).


How can I flip the video feed from the laptop's built-in webcam, as to properly see and broadcast the video?

share|improve this question
I assume holding the laptop upside down is not an option :). – Brad Patton Sep 24 '12 at 18:50
@BradPatton Dang, that was my idea. – Jeff F. Oct 18 '12 at 19:51
up vote 1 down vote accepted

Here are two threads full of solutions that worked for some people.

The funniest remark was that it is not a driver issue but an Asus one, because the camera is really physically installed upside-down. So one solution is to find a technician that can flip your camera. Or if the computer is under warranty, demand it of your vendor.

How to Fix the Problem of ASUS Upside Down Webcam

Solutions in this thread:

  1. Modify WebCam setting, if the software allows it
  2. Download a Webcam Driver from the ASUS support site corresponding to your hardware PID
  3. Update Webcam Driver with Driver Detective
  4. Edit registry at HKEY_LOCAL_MACHINE\SOFTWARE\Sunplus SPUVCb\VIDEOPROCAMP, set VFlip value to 1.

Built-in camera upside down

Solutions in this thread:

1) adjust the settings

Run the camera through the Windows Explorer. Your camera built-in will appear upside down, right?
Inside the folder with the drivers provided by ASUS there´s a software called tsnp2std.exe.
With your camera opened, run this application; you will notice a small icon in tray area; right click on it and now choose the option: Open Property Page.
Well, now you should not have problem to setup and adjust the settings.

2) Reinstall driver with flip

I resolved it by editing the snp2uvc.inf file. Open it with notepad and search for the word "flip". You'll see entries like this:
HKR,DefaultSettings,Flip,0x00010001,0 and HKR,Settings,Flip,0x00010001,0.
Change the last digit (zero) to a "1" to all instances. Save the file and re-install your drivers manually from Device Manager. Choose the driver to install, do not let Windows search for you.
Reboot and your video will be in the correct orientation.

3) Roll-back the driver to the original one that came with the computer

share|improve this answer
After reading the aditional information from your answer, I started to test even older drivers from Asus. I've been successful solving this problem, by using the MVI-SV1103-AD Camera Driver for Vista from 2007.10.25, available from an Asus model search with this parameters. – Zuul Oct 22 '12 at 15:17
After installed, I didn't had to change any settings at all, all was OK. Thank you for the additional help on this matter. (If you wish, add this driver reference and the link I've provided to your answer, as to have it with the solution that definitely solved this question.) – Zuul Oct 22 '12 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .