Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to work out a problem in Word that I thought was simply a glitch from 2003 until we upgraded to 2010 and the problem persisted.

For our corporate letterhead, we set up the template with placeholder text, highlight the text, and then make the document read-only with the exception of the selected text. The editable text turns yellow and gains these brackets around them:

Brackets around editable text - beginning Brackets around editable text - end

Once these brackets appear, they'll always show on the screen. That I can handle, though I'd like to learn how to hide them on-screen if that's possible. When the document is printed while protected, it works fine.

When the document is printed while NOT protected, part of the bracket shows up on the paper!

Brackets around editable text - beginning - printed Brackets around editable text - end - printed

I guess the ultimate question is, how can I get rid of the brackets altogether? I can see why they exist but in my use case they create more problems than they solve. I'd like someone to be able to read the doc without seeing brackets, and I'd like other people in my department to be able to print without having to re-restrict it first.

I tried to turn off bookmarks because that's what seemed to come up when I searched around, but that didn't do anything.

EDIT - 12/18/2012:

As requested in a comment below, here's a slimmed-down file that demonstrates the problem. Printing that should show the gray lines. If you protect it again it'll print okay, and if you remove all protection and exceptions it'll print okay.

share|improve this question
    
I can't reproduce it on my side, can you simplify your document and attach it somewhere? –  Adam Dec 18 '12 at 11:06
    
@Adam edited post to add! Thanks for your interest :) –  Brendan Dec 18 '12 at 18:56
    
Thanks for that and sorry for taking so long to get back to you. I will post my finding as an answer. –  Adam Jan 2 '13 at 4:07

2 Answers 2

up vote 2 down vote accepted

I can reproduce the same issue with your test document. I have taken a look at the XML inside the document and found that there are no extra elements around the text that could possibly be causing the problem so that behavior is just a bug of Microsoft Word.

Further to your issue I found no way of removing the yellow brackets around editable ranges when document protection is enabled. My guess is they are there to show users what part of the document they can edit so there was never thought of an option to turn them off.

I can suggest one other way to achieve what you are looking for which can avoid both of the issues you are facing. Use protected sections with filling in forms enabled instead of editable ranges:

  1. Firstly insert continuous section breaks around the content want to remain editable.
  2. Click on Restrict Editing from the Review toolbar
  3. Under Editing Restrictions choose Filling in Forms.
  4. Click Select Sections underneath and select all the other sections that are not part of your editable content, for example in your simple document that would be Section 1 and Section 3.
  5. Click Start enforcing protection.

What you should find after this is done is you can still only edit that particular part of the document and not the rest of the document, however now there are no yellow brackets as you desired and also should be no artifacts when printing. Obviously I'm assuming your other sections do not contain form fields otherwise they will be editable.

share|improve this answer
    
Thanks for your interest, your research, and your answer. And for the workaround too; I'll have to give that a try! –  Brendan Jan 2 '13 at 15:00

I found that in the Protect Document settings, there is a box "Highlight Fields I can Edit" and if I uncheck the box, the brackets go away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.