Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having issues connecting to the various devices on my network (Mac-heavy, MBP (thunderbolt, not retina, Lion), Macbook (Late 2007, white, Snow Leopard), iPad (3rd gen, iOS6), Apple TV (2nd gen, latest OS), and HP Inspiron Zino HD (Windows 7)). Each device has no issues getting onto the internet (with an odd exception of Google search taking a long time to become available on my MBP– it fails to connect even after I've hit up http://www.apple.com and http://www.bing.com manually, then after a few minutes figures out what's going on).

I use a Belkin N150 wireless router and a Motorola SURFBoard SB6121 cable modem on Cox Cable.

Probably unnecessary, provided for the sake of completeness: My DNS servers are set to 8.8.8.8 and 8.8.4.4 on the Belkin N150.

Behaviors I have observed:

  • When trying to SSH, ping, or SFTP into the MBP (or out of it) via the host name, the message returned is

    Could not resolve hostname $HOSTNAME: nodename nor servname provided, or not known

  • Occasionally, after flushing DNS cache (via sudo killall -HUP mDNSResponder per http://forums.macrumors.com/showthread.php?t=1254720), the DNS works and I can connect to other devices.

  • nslookup:

    $ nslookup $HOSTNAME
    Server:     192.168.2.1
    Address:    192.168.2.1#53
    
    ** server can't find $HOSTNAME: NXDOMAIN
    
  • dig:

    $ dig @router $HOSTNAME
    ; <<>> DiG 9.7.6-P1 <<>> @router $HOSTNAME
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 6596
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;$HOSTNAME.     IN  A
    
    ;; AUTHORITY SECTION:
    .           1788    IN  SOA a.root-servers.net. nstld.verisign-grs.com. 2012092401 1800 900 604800 86400
    
    ;; Query time: 179 msec
    ;; SERVER: 192.168.2.1#53(192.168.2.1)
    ;; WHEN: Mon Sep 24 15:34:34 2012
    ;; MSG SIZE  rcvd: 111
    

It's definitely not just the computer; I've tried it with both of the macs, without luck.

router/ does redirect appropriately to the belkin admin page.

The network settings only specify the router's IP under DNS for the MBP.

Tethered network from the iPad to the MBP works perfectly fine.

I'm working on an app that needs to talk to a server that I run on my local machine, so having a functioning network would be good; I'd also prefer to not have to replace the router, though I will if it's just a total POS.

Thanks in advance.

share|improve this question
    
Sounds like your Belkin router is acting up. Have you tried rebooting it? –  Michael Hampton Sep 24 '12 at 22:46
    
I did yesterday morning (when it booted everything in the house off the network). I'll give it another kick in the pants, though. –  Chaosphere2112 Sep 24 '12 at 23:01
    
No dice on the reboot; nslookup is still giving me NXDOMAIN, as is dig. –  Chaosphere2112 Sep 24 '12 at 23:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.