Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to login to my Windows 7 PC from another PC so that I can transfer files to the Windows 7 PC. I've just installed Visual Studio 2008 on my new PC, and I wan't to transfer all of my work from my old machine to my new one.

When I first set up a user on the Windows 7 PC after a reformat, the account created had a Group field that read "HomeUsers; Administrators" when viewing it from the User Accounts screen. You get to this screen by typing "netplwiz" in the search field of the Start Menu.

I changed the Group of this account to Administrators before I realized that it was assigned to two Groups --> "HomeUsers; Administrators" as I mentioned above. I was trying to make sure that it was an Administrator account so I didn't have to type in a password everytime I wanted to install software.

I can use this computer normally without being asked for an administrator password all the time when I want to install new software, but I can't log in to this PC from another PC because I don't have an account that has a Group of "HomeUsers".

I should have left the account alone; everything would've been fine.

But there doesn't seem to be a way to assign it to two groups after the initial assignment that take place automatically when you are setting up your computer for the first time. If you assign "HomeUsers" to the account, the Group field on the User Accounts screen will just read "HomeUsers". If you assign "Administrators" to the account, the Group field on the User Accounts screen will just read "Administrators". There's no way to make it read "HomeUsers; Administrators" again.

If you don't have at least one account that is a "HomeUsers" account, you cannot log in to the PC from another PC on the network. If you don't have an account that is an "Administrators" account, you cannot install software on your machine without being asked for an Administrator password all the time, which is very annoying.

I want an account on my Windows 7 PC that I can use to install software without being asked for a password AND that I can log into from another PC on the network to transfer files.

If I could make the Group field read "HomeUsers; Administrators" of my primary account on the Windows 7 PC when I go to the User Accounts screen by typing "netplwiz" in the search field of the Start Menu, my primary account would do what I want it to do.

Does anybody know how to make an account in Windows 7 a "HomeUsers" account AND an "Administrators" account? As I said before, Windows 7 does this for you automatically when you first set up your computer. But if you change it inadvertently, there is no way to change it back. At least I don't know how to do it. If anybody has any ideas on how to fix this, I would greatly appreciate it.

Thanks,

Charles Carrington

share|improve this question

migrated from stackoverflow.com Sep 24 '12 at 22:41

This question came from our site for professional and enthusiast programmers.

3 Answers 3

You should try to system restore to a point before you changed "Home Users". If this doesn't work and you are very desperate then you should do a full restore back to the factory settings. Hope this helps!

share|improve this answer

I have figured out the solution to this problem. To make an account a HomeUsers account AND an Administrators account so that it reads "HomeUsers; Administrators" when viewing it from the User Accounts screen accessed by typing "netplwiz" in the search field of the Start Menu, first change the type of that account to a Standard Users account. Do this from the Users Account screen accessed by using "netplwiz". You have to right click on the account and then click on Properties. In the window that pops up, go the the Group Membership tab to change the account type. Once you have made the selection and clicked OK, click Apply or OK on the User Accounts screen. Then, open up Control Panel, click on User Accounts and Family Safety, click on Users Accounts, and then click on Manage another account. The account you want to be a "HomeUsers; Administrators" account should show up as a selectable account to manage. While this window is open, type "netplwiz" in the search field of the Start Menu to go the User Accounts screen again. From this screen, change the account type to HomeUsers. HomeUsers is listed in the dropdown that says "Other:" on the Group Membership tab of the Properties window. Once you have made the account a HomeUsers account, click OK on the User Accounts screen to apply the changes and close the Window. Now, go back to the Manage Account window that you accessed from the Control Panel that should still be open. Click on the account that should be a "HomeUsers; Administrators" account. Change the account type to Administrators and click ok. The account should now be a "HomeUsers; Administrators" account. If you open up the User Accounts screen again by typing "netplwiz" in the search field of the Start Menu, the group field should read "HomeUsers; Administrators". Now you can install software with this account without being prompted for a password AND log into this account from another PC to transfer files.

share|improve this answer

To add your user back to the HomeUsers group, open a command prompt as an administrator. Then run the command net localgroup HomeUsers your_username /add.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.