Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i am having a problem with booting my PC...After plugging my wireless network adapter in a usb port(does not matter which), it takes 30 secs to pass the bios check and start windows loading. If I unplugged the adapter, it passes bios check in 2 secs... My mobo is a gigabyte z77-D3H.

share|improve this question
    
You left out the most important information -- what precisely is happening during those 28 extra seconds? What's on the screen? Where in the boot process does the delay happen? –  David Schwartz Sep 25 '12 at 8:40
    
On the screen you can see the Logo of the MOtherboard and nothing else :p after 30(or more) seconds windows starts loading and it takes about 8 seconds from there to see the desktop. –  mbD3H Sep 25 '12 at 10:05
    
can you go into the BIOS and disable the "show boot logo" option and tell us what is written on the screen instead? maybe your PC is trying to boot from USB or from Network. –  Crujach Sep 25 '12 at 10:26
    
I will do it when I go home and I will inform you –  mbD3H Sep 25 '12 at 10:45
    
It shows nothing...Only "American Megatrends" logo. –  mbD3H Sep 26 '12 at 7:23

1 Answer 1

It could of course be a problem with the bios routines for USB or network adapter discovery; which would make the self-test take a long time, but I doubt that.

Likely what you are seeing is the BIOS attempting a PXE boot, which requires it to try to obtain a network address by DHCP. This fails for some reason, likely because it can't connect to your wireless network without knowing its SSID (and encryption key).

To avoid the problem, change the boot order (in the BIOS settings) to try the hard disk before the network.

The PXE boot should happen after the self-checks and have some information on what's going on printed to the screen (just like the self-checks), try reading the text that shows up to make sure this is the problem. If you can't see any text at all or it does not change, you may want to disable silent boot, quiet boot, splash image or similar in the BIOS settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.