Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 Starter and whenever I travel to Korea I like to try to practice typing Korean.

I have the Windows Input Method Editor (IME) installed and I know I can toggle the input mode between typing Latin (English) characters latin mode and typing Hangul (Korean) characters hangul mode by taking my hands from the keyboard, grabbing the mouse, and clicking on the little icon shown which changes between an A and a symbol.

But I lose the positions of my fingers on the keyboard when I do this, and in any case it slows me down a lot. Usually I switch between the two a lot.

So is there a way to switch without using the mouse? I can't seem to find a keyboard shortcut for it anywhere.

share|improve this question
    
What about ctrl+shift ? –  Lamb Sep 25 '12 at 11:52
    
@Lamb: No ctrl+shift does nothing. I tried all combinations of left and right keys ... –  hippietrail Sep 25 '12 at 11:59
    
Are you sure you didn't changed the shortcuts ? Advance Key Settings tab (in the Text)has option for setting custom shortcut. Check there if it shows ctrl+shift or not. –  Lamb Sep 25 '12 at 14:01
    
I do have the setting in Advanced Key Settings for Switch Input Language = Left Alt + Shift and for Switch Keyboard Layout = Ctrl + Shift. But it seems neither of these changes the Latin/Hangul mode. Ctrl + Shift does work for another language I have installed, Georgian, which has two layouts but it does nothing for Korean. –  hippietrail Sep 25 '12 at 15:27
    
Its strange, I tried same set of languages on my system it works perfectly. I guess that shortcut in Korean is set to none, Try using the Change Key Sequence and change it to something like Ctrl+1. (This can work as an alternative) –  Lamb Sep 25 '12 at 16:30

4 Answers 4

up vote 1 down vote accepted

AltGr+Shift (or right Alt+Shift) changes between Latin and Characters.

(Left) Alt+Shift changes the different language keyboards.

share|improve this answer
    
I don't know why this was downvoted, I just tried it with the Microsoft Korean IME under Windows 7 and it works. Just what I'd been wanting for years! The answer might be better with a link describing it I suppose. –  hippietrail Jan 4 at 2:14
    
Oddly I misread the answer as having to press right Alt + right Shift. Even though it didn't actually say that, that in fact worked. So I've edited it into the answer. Thanks Annyong! (-: –  hippietrail Mar 7 at 11:13

Right Alt will work - only if you are in editing mode (i.e. typing something in some textbox and not browsing windows etc)

Left Alt + Shift will switch between languages. You can modify this setting easily in the Languages/Keyboards setting.

share|improve this answer
    
In fact I've just discovered after reading your answer that either Left Alt or Right Alt works! There can be a weird interaction between this function and the Windows function of switching the menu in and out of a "hotkey mode" though. (I always knew how to switch languages, that was never a problem.) –  hippietrail Aug 9 at 7:38

I had this problem and found out that at least for me the button is Alt Gr.

This is because in Korean keyboard layout there is a button Ha/En there as seen in this picture (I don't have enough reputation to post an image, so here is a link):

Hangul layout

Alt+Shift changes between language layouts. This is different.

share|improve this answer
    
Hmm I don't have an <kbd>Alt Gr</kbd> key on my English-layout HP netbook )-: I'm reading online that either my right <kbd>Alt</kbd> key or <kbd>Ctrl+Alt</kbd> should do the same as <kbd>Alt Gr</kbd> but that doesn't seem to be the case for this IME )-: –  hippietrail Jun 1 '13 at 16:08
    
It turns out just clicking either left or right ALT does the trick! –  hippietrail Aug 9 at 7:35

FOR USERS WITH AN ACTUAL KOREAN KEYBOARD

with HANGUL/HANJA keys

Hey, I was just trying to figure this out and I have a FAR better answer. On standard Korean keyboards there are langauge input keys to the left and right of the spacebar. The reason you can't get them to work is because you have to choose "Korean" as the default input language. Then, you can make the Hangul keys work. Don't use the clunky MS shift+ blah blah.

Steps for Win 7 - Assuming that you have installed the Korean and Chinese langauge packs already:

1) Click the Windows button and go to the main Control Panel (has 8 icons)

2) Select "Change Keyboards or other input methods" under Clock, Language, & Region.

3) Select the Keyboards and Languages Tab. Then click the "Change Keyboards" button

4) Under the General Tab, you must click "add" and select the Korean Keyboard format Office IME 2007, which was suggested as a default. Now, if you currently have a US keyboard installed in the list, remove it. Don't worry. Korean keyboards are laid out in QWERTY format, so all the English letters are still in the same place and you can type exactly the same as on a US Keyboard, but now with the Korean/Hanja embedded characters as an option. If you leave the US keyboard in the list, you might accidentally switch and get really angry later when you can't understand why the Korean keys suddenly stop working. Save yourself the frustration and remove it from the list now. Also, if you don't have a physical Korean keyboard sitting on the desk in front of you, then this won't do anything for you and you should keep your existing keyboard setting unless you buy a sticker pack for your keys.

5) To check that you are finished with the first part, click the main Windows button on the bottom left and type "osk" in the search bar. OSK is "On Screen Keyboard". If the Hangul/Hanja Keyboard layout appears, you're in business.

6) Last step. Your web browser is stupid. You will have to click settings and within the "General" tab, choose "Languages". You must add any languages that you either want to SEE or be able to TYPE with. That means, you can't do anything properly in Korean on the Web until you have added the Korean language options in "Language Preferences". The Hanja key works, but I don't know if the browser will display Chinese material correctly without adding the Chinese languages in the browswer settings too. My language skills are limited there, so you'll have to experiment on your own.

Special note:In order to access the Hanja (Chinese characters), you must highlight the word typed in Korean and then press the Hanja key, which is to the left of the spacebar. A drop-down menu of potential Chinese characters will then be offered.

The actual Korean keyboard keys are much faster and more satisfying than dorking around with the mouse and clicking the doofy language bar settings. Also, one final note, be sure to install all the windows updates that will appear AFTER you install language updates. They are needed architecture and updates to make the OS multilingual.

Good luck and I hope that this helps someone.

share|improve this answer
    
Step 4: I think a lot of users won't have Office IME 2007. I've never bought Office so don't have it. I wouldn't recommend uninstalling the English keyboard layout. Many of us use more languages than just Korean and English. Step 6: Many of us don't use the same "stupid" browser. This might be something only MSIE needs? I doubt many people with actual Korean keyboards don't know how to use them anyway, but the answer would be improve with an image of the special keys or at least what's written on them. Useful if you're starting to learn Korean in Korea so have the keyboard but lack the vocab. –  hippietrail Mar 7 at 11:24
    
I can't actually test this because I don't have a Korean keyboard and I'm not in Korea at the moment, but I might be there in a few weeks where I'll be able to test it on another computer. –  hippietrail Mar 7 at 11:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.