Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a setup like, main router is connected to modem(ISP), I have connected one wifi router to main router, and another wifi router to above wifi router, so have 3 levels of routers. Now I connected one UDP client to wifi router at level 2 and other UDP client to wifi router at level 3, and tried to send/receive packets, but they were not able to receive packets.

I tried running skype for same setup but skype was also not able communicate peer-to-peer, it was sending packets through servers.

Also when I am connecting one client with main router and other client at any level of wifi router then they are able to communicate.

Help needed... Thanks in advance.

share|improve this question

migrated from stackoverflow.com Sep 25 '12 at 14:00

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 0 down vote accepted

Disable NAT on your 2nd and 3rd routers. If your routers don't provide a way to disable NAT, then stop using their WAN ports; just daisy-chain them LAN to LAN to LAN. Hopefully they provide a way to turn off their DHCP servers; otherwise you should set the DHCP pool/range to zero-length on all but the first router.

If the ISP modem is more than just a modem and actually does NAT and DHCP as well, then you should stop doing NAT and DHCP Server on even your first Wi-Fi router.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.