Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently got a MacBook Pro. It connects to ethernet\wifi and has internet but when I open Safari or Firefox, nothing happens. I get a timeout for all websites.

I had Covenant Eyes on my Mac before and tried to remove it.

My friends who work with computers have tried everything (ping, nslookup etc).

  • Network diagnostics show no problems
  • I can see I'm connected through ifconfig because I get an IP.
  • I also get a response pinging www.google.gr.
  • There are no proxies set in my Network preferences.

Any ideas?

share|improve this question
    
yes it worked until i made a new account. nothing else connected than the mac . When i made a new account it worked , i left it to sleep for an hour and after i got it back on it didn't work –  Joanna Sep 25 '12 at 20:55
    
Have you looked at this page: covenanteyes.com/support-articles/… ? –  user142485 Sep 25 '12 at 21:29
    
the thing is that I don't have the codes I need to uninstall covenant eyes because someone gave me the mac without me knowing that it contains passwords and now that person is in Australia and I'm in Greece.... :\ –  Joanna Sep 25 '12 at 21:35
    
I do not know how that software works but if this (www6.nohold.net/Cisco2/…) doesn't work, you may need to call their support. –  user142485 Sep 25 '12 at 21:38
    
it doesn't work, I'll probably call support. however, do you know how to get mac os 10.6.4 for reinstall cause I don't have original dvd? –  Joanna Sep 25 '12 at 21:45

1 Answer 1

Be sure that you've removed it completely. The current version of Covenant Eyes for Mac (2.8.3) leaves the following files:

  • /usr/libexec/CvntDaemon
  • /Library/LaunchAgents/com.Cvnt.start.plist
  • /Library/LaunchDaemons/com.Cvnt.daemon.plist
  • /private/var/db/receipts/com.Cvnt.CovenantEyes.bom
  • /private/var/db/receipts/com.Cvnt.CovenantEyes.plist
  • /Library/Extensions/Cvnt.kext
  • /Library/Extensions/CvntDriver.kext
  • /System/Library/Extensions/Cvnt.kext
  • /System/Library/Extensions/CvntDriver.kext
  • /Applications/Covenant Eyes.app
  • /Applications/Utilities/Uninstall Covenant Eyes.app
  • /private/var/.ce/*

Make sure you've removed ALL of them. The lists I've found for removal did not include the files at /Library/Extensions/Cvnt* which means that while it would ping, trace and respond to web services, it would still fail to connect to websites.

You'll need to unlock the kext files with the following before you can delete them:

sudo -s
chflags nouchg /Library/Extensions/Cvnt.kext
chflags nouchg /Library/Extensions/CvntDriver.kext
chflags nouchg /System/Library/Extensions/Cvnt.kext
chflags nouchg /System/Library/Extensions/CvntDriver.kext

After removing those files you may also have browser extensions installed that need to be removed through the browser itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.