Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've done a clean install of Windows 7 x64 on an ASUS X501A laptop. The battery is detected and shows in the system tray as "plugged in, charging". However the charge level stays at 76% and if the AC cord is plugged out the laptop turns off. The laptop does not turn on without being plugged in either. Everything worked perfectly prior to reinstall.

I've tried:

  • Downloading and installing all the ASUS drivers, including the ATK ACPI driver
  • Checking the BIOS - there do not seem to be any battery-related settings
  • Flashing the BIOS to the latest version
  • Uninstalling Microsoft ACPI-Compliant Control Method Battery in device manager as suggested on the internet
  • Full power discharge/ATX reset as suggested by ASUS support: remove mains power charger, remove battery, press and hold power button for 10 seconds, reconnect battery and mains and turn on

I have a feeling all this may have something to do with the EFI BIOS that comes on the laptop. During the reinstall I had to delete all partitions and start anew, because the Windows installer complained about the improper order of GPT partitions. The EFI System Partition was recreated by the installer, and I am guessing that it may be missing the particular ACPI driver needed to make the battery work.

I've tried researching this, but could not come up with any useful info. I am hoping someone here may know a bit more about this and maybe help me understand what's going on and how to fix it. Barring that, I'll have to re-image the drive off an identical ASUS laptop with stock install and hope it fixes things.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The fact that the system cannot even turn on from power off without the cord plugged in tells me that the battery hardware is most likely the culprit. You see, the operating system, the hard drive, EFI, all of this occurs way after the BIOS itself performs basic hardware initialization during very early boot. If the battery cells themselves and the connector between the battery and system are intact, then it could be a battery firmware bug.

Certainly it is plausible that there could be battery charging or capacity reporting bugs in the operating system after boot, but these types of problems cannot manifest, by definition, during the stage of boot where the operating system plays NO role whatsoever -- during BIOS initialization.

If fans don't spin / screen backlight doesn't light up / BIOS loading screen do not display when you press the power button with the AC removed, then the battery itself is likely damaged. Or, much less likely, a BIOS update broke it. This is so unlikely because they test BIOS firmware a lot before pushing it to customers, and everyone else would be complaining about the same problem.

share|improve this answer
    
You're right, the problem is with the battery. I just tested it in another laptop and it doesn't work. But how could reinstalling Windows break the battery - is that possible? –  Stan Sep 26 '12 at 0:41
    
It's incredibly unlikely that reinstalling Windows would cause hardware damage to the battery. It is more likely that the battery broke coincidentally right as you were reinstalling Windows. The sequential occurrence of two events does not imply causation. –  ÃŁŁǫǛȉЖΦΤїҪ Sep 26 '12 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.