Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One worksheet doesn't show the first 15 rows. I tried the followings, neither worked, even in full-screen mode

  • Step 1: F5 (Ctrl+G) to define & select 1:15, set row height to 20 and "unhide row", they are still hiding;

  • Step 2: Put cursor in A16, then up.. till A1 (invisible), select entire row (Ctrl+Shift+), hold on Shift key, press , till all 15 rows selected, set height and unhide row, still doesn't work!

How can I get them back?

share|improve this question

migrated from stackoverflow.com Sep 26 '12 at 0:38

This question came from our site for professional and enthusiast programmers.

3  
Your question does not seem related to programming –  belisarius Jun 25 '10 at 13:16
    
It's formating :-) –  PerlDev Jun 25 '10 at 13:18
    
Select all rows, paste them into a new worksheet, all rows show up –  PerlDev Jun 25 '10 at 13:19
    
could you maybe post a screenshot of your worksheet with the hidden rows? have you checked if there are any addins/vba-macros active - linke Wokrsheet_change? Could you add a screenshot of your VBE with the problematic workbook opended in? –  Jook Sep 24 '12 at 9:52

6 Answers 6

Try the following:

Type the first cell reference A1 in the Name Box and press enter. On the Home tab, click on the Format icon Choose Hide & Unhide from the dropdown menu then select Unhide Rows.

You should be able to unhide all of the rows inbetween after that.

share|improve this answer
    
Nope, it doesn't work either. I tried the following VBA code, not work either: ` Sub test() Dim rng As Range For i = 1 To 15 Set rng = Rows(i) rng.Locked = False rng.RowHeight = 20 rng.Hidden = False Next Set rng = Nothing End Sub ` –  PerlDev Jun 25 '10 at 13:51
    
Tried all the solutions listed in spreadsheets.about.com/od/excelformatting/qt/…, none of them works. –  PerlDev Jun 28 '10 at 13:24

I removed my filter from the whole worksheet and everything appeared. Then I highlighted everything I wanted filtered and re-applied the filter.

share|improve this answer

Also, be careful that you haven't got a frozen pane. This can cause all sort of problems.

From View, look under Window and for Freeze Pane, there's an Unfreeze Pane option.

This one drove me nuts for half an hour until I realized what was going on. Unhide on its own didn't work. Neither did changing row height. Frozen panes are very subtle.

share|improve this answer

Highlight the rows you want unhidden. Double click on the space between the rows in the numbers column, (on the left side) your mouse pointer icon will change from a pointing right symbol to an expansion symbol. The hidden rows will show themselves.

share|improve this answer

I had the issue you were describing and found that the rows were unhidden, but the row height was zero. So, unhide the rows as you describe and then hover over the row symbols on the side (in between the two rows where your rows are hidden) and then click and drag to expand the row height manually.

There's probably a visual basic script to do this that you could code up as well.

share|improve this answer

Select the Sort & filter icon from the home menu bar, uncheck the Filter button.

To me, it looks like bug in Excel filters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.