Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a drive image made in Acronis of an XP machine. The original computer has a C:/ drive, an E:/ partition, and a CD drive on D:/. When I restore from the backup, the E and D drive letters are switched. How can I prevent this from happening?

I suspect it has to do with the MBR, but beyond that I'm lost.

share|improve this question
    
I think it has something to do with the fact that the second partition will be detected before the CD drive, so therefore gets priority with the Drive letter. – Jeff Kranenburg Sep 26 '12 at 2:22
    
I neglected to mention that it had been working previously for quite a long time. Something happened to change it. – David Sep 26 '12 at 3:04
up vote 0 down vote accepted

If you run diskpart, you can probably use

list volume
select volume N
assign letter=E

(where N is the number of your partition you want to be E:, found via the output of list volume)

Since the hard drive volumes get priority over the CD drive, as you suppose, this'll cause C: and E: to be allocated, so the CD drive gets D:.

Good luck!

share|improve this answer
1  
Only had the opportunity to test it right now. I ended up setting the CD drive to F. Thank you. – David Sep 27 '12 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .