Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I feel like I must be missing something obvious.

I'm on Mountain Lion. I'm trying to use a directory that isn't in my /Library/WebServer/Documents/ directory. I've tried the following, in order:

  • a symlink
  • an alias
  • creating a virtual host for that directory

Nothing works. Even if I open my config way up, even if I do crazy stuff like

<Directory />
  Order allow, deny
  Allow from all
</Directory>

or chmod -R 777 . – nothing works.

My error log is full of (13)Permission denied: access to / denied.

I've added

<Directory "/Users/gormster/Documents/MySiteHere">
Order allow,deny
Allow from all
</Directory>

to my httpd.conf. Now I'm lost.

share|improve this question
    
verify that the user that the web server is running as has access to the entire path "/Users/gormster/Documents/MySiteHere" and any files in that directory that you are trying to read. The directory permissions need to be at least r-x and the file permissions need to be at least r--. –  Yedric Sep 26 '12 at 19:26
    
Yeah like I said I did crazy shit like chmod -R 777 . which will obviously grant rwx to all. –  Morgan Harris Oct 3 '12 at 2:38
    
If you put content in /Library/WebServer/Documents, and change your Directory statement to match that, does it work? Trying to verify whether it is an issue with the configuration that is not related to the directory in use or if it is a security related issue. –  Yedric Oct 3 '12 at 13:46
    
Are you using the Mountain Lion Server (the default) or have you enabled Apache HTTPD? –  Yedric Oct 3 '12 at 13:57
    
If I put it in /Library/Webserver/Documents yeah that works fine. I ended up doing this, which fucks up my directory structure, but oh well. –  Morgan Harris Oct 17 '12 at 5:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.