Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Excel 2003 on my new Windows 7 machine. (There is also a Excel 2010 starter pre installed that I do not use).

I'm a heavy user of Excel. I use it all day every day. I often have 10 or 15 sheets open and once and many of them have cell references to each other. I also have a macro file that keeps all my short cuts.

On my old W2K machine when I clicked on a .xls file or a shortcut to one to it would open that file in the existing instance of Excel. This is as it should be. I would have many files open, in only one "window" or instance of Excel. All the files could interact with each other, the cross file lookups worked, my macros worked and I could switch between workbooks with CTRL Tab or CTRL F6, I could move tabs from one workbook to another.

On the new W7 machine clicking on an icon opens a NEW INSTANCE of Excel every time. This is terribly frustrating. None of my connecting spreadsheets work anymore. My macros don't work. I can't connect files, I can't move tabs. I'm stuck. I can't do my work!

I can still open files in one instance by doing a CTRL-O and navigating, but I need to my files to work on a click.

I'm guessing this is a flaw in the registry files, possibly because of the starter Excel 2010 that came preloaded on my new machine.

Can you walk me through a registry edit to fix this bug? Is there an easier way than a registry edit?

share|improve this question
    
Not an answer, but a walkaround: You don't need to ^O. Excel supports Drag&Drop, so make shortcuts to the files you use, and drag & drop them into Excel. –  Adam Ryczkowski Sep 26 '12 at 7:58
1  
Anyway, the behavior you describe is not normal, even for Windows 7. Try uninstalling & repairing, just as HaydnWVN have suggested. –  Adam Ryczkowski Sep 26 '12 at 7:59
    
Uninstall Excel 2010 and try repairing Office 2003 first. If that doesn't work, uninstall and reinstall. –  Karan Sep 26 '12 at 16:37
    
This is very normal behavior if it's the way his settings are configured. –  Brad Sep 26 '12 at 17:23
    
Did any of these answers work for you Mark? –  Brad Oct 8 '12 at 16:36

5 Answers 5

I had a similar problem with Excel 2010 on W7 and repairing the installation did not seem to do the trick, and the ignore DDE option was already unchecked. My shortcut icon for Excel files was also unusual, although all registry entries in classes_root seemed fine (although I suspect some minor thing was incorrect but I have not done a snapshot to spot the difference).

To fix it, I did this:

  1. Find an Excel .xlsx file
  2. Shift + Right-click > Open with...
  3. Ignore the options presented and click Browse
  4. Navigate to my install of Excel 2010 (so in my case this was in

    C:\Program Files (x86)\Microsoft Office\Office14
    
  5. Double-click on Excel.exe

  6. Make sure the previous dialog has a tick in the box for "Always open..."
  7. Click OK

Now my Excel files open in a single instance as revealed by Task Manager, and my icon is correct. I can force a second instance easily by using Shift + clicking on the shortcut on my Windows 7 taskbar to start Excel as a new process then opening a file from in there (if I want to view a second file on a second monitor for example and don't need to paste between files)

share|improve this answer

Excel Options -> Advanced -> Display -> Remove the checkmark beside "Show all windows in the Taskbar". You are done.

share|improve this answer

Uninstall the Office 2010 which came pre-installed.

Uninstall Office 2003.

Run sfc /scannow to fix any underlying Windows problems.

Install all Windows Updates.

Reinstall Office 2003.

Install all Windows and Office 2003 updates.

Try again!

share|improve this answer

You can change this setting in the options. If you happen to have this checked:

Excel Options > Advanced > General > Ignore other applications that use Dynamic Data Exchange

it will behave like you describe. (this path is for Office 2010/2007, I'm not sure of the exact path for 2003 but it should be in there somewhere pretty close to this)

Edit: Here's the path for this fix in 2010, 2007, and 2003.

When this is checked, every time you open a new Excel file from Windows Explorer, Excel will force a new instance to be created. It's nice to have when you have multiple monitors and you want to look at two files at once without doing annoying window manipulations. It still allows you to open files in the current instance when you open then from within the instance itself. The problem that arises is that copy and pasting is not as elegant. you can only C/P as text or HTML or some other annoying format. And you usually lose your formulas.

If this option is already unchecked I'm not sure when the issue could be. But, I would say it's not necessary to have Office Starter on your computer once you have a real Office instance installed. I'd be deleting that whole Starter package if I were you.

share|improve this answer

I had the same problem. Did so many searches and nothing worked. Finally - I recalled messing it up when I first installed Excel 2003.

The fix?

Right click an Excel file in Windows Explorer and re-select the default program. (Open with --> Choose Default Program...).

Fixed!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.