Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to clone a repository using git on cygwin.

Machine is a Windows XP machine, running a newly updated version of cygwin

I have cloned this repository without any trouble previously, but on a new machine I get this issue:

buildmeister@winbuild /cygdrive/d
$ git clone git@github.com:gollumullog/test.git
Cloning into 'test'...
remote: Counting objects: 3, done.
Receiving objects: 100remote: Total 3 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (3/3), done.
error: inflate: data stream error (invalid code lengths set)
error: failed to read object 14007e4054f6c7c33e03975c480ba9986510d4ff at offset 12 from /cygdrive/d/test/.git/objects/pa
ck/pack-ad4395202f65ea50c9cef2e4fc4a5d9cca8321bc.pack
fatal: packed object 14007e4054f6c7c33e03975c480ba9986510d4ff (stored in /cygdrive/d/test/.git/objects/pack/pack-ad43952
02f65ea50c9cef2e4fc4a5d9cca8321bc.pack) is corrupt

The above repository is just a stub I created on github with only a readme file in it.

Any help diagnosing the issue would be greatly appreciated.

Notes: - I have seen some weird permission issues on this machine, and wonder if this is related: ie I create a folder using explorer in windows, and the permissions set appear to be d---------+ when I examine in cygwin, but I can cd to it, and create files in it, etc.

share|improve this question

migrated from stackoverflow.com Sep 26 '12 at 11:08

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.