Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run an hourly python script. My crontab looks like this:

crontab -l
0 * * * * "/common/.../www/concat.py /common/.../www"

as an output I get this:

/bin/sh: /common/.../www/concat.py /common/.../www: No such file or directory

It makes no difference if I leave away the "" in the crontab. The argument is needed to set the current working directory in python. What am I doing wrong?

Found the bug:

0 * * * * needs to have a space as a whitespace. I used tabs.

share|improve this question
    
Does the command work at all when typed in a terminal? – m4573r Sep 26 '12 at 16:12
    
yes it does. I copied it and pasted it and it worked. – Benedikt Wutzi Sep 26 '12 at 16:14
1  
What is the /.../ ? – RedGrittyBrick Sep 26 '12 at 16:22
    
a bit I left out, because it is running on an official machine with official usernames – Benedikt Wutzi Sep 26 '12 at 16:24
    
Is this a cron job for the root user or a "regular" user? Could it be that the user that you have created the cron job for, does not have privileges to access the files/folders that you have specified? – p_strand Sep 26 '12 at 16:52

Try it without the quotation marks around the command in crontab

You really don't have a file named /common/.../www/concat.py /common/.../www

Note that "concat.py " would be a valid directory name just as "Program FIles" is a valid directory name - the space is part of the name. Names containing spaces are quoted.

share|improve this answer
    
I already tried that. – Benedikt Wutzi Sep 26 '12 at 16:29
    
@BenediktWutzi: try it again :-) – RedGrittyBrick Sep 26 '12 at 16:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .