Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When there are multiple input methods (keyboard layouts) installed, the first one in the list is supposed to be the default. In my case I have two custom keyboard layouts:

  • US (Customized)
  • Czech (Customized)

My currently installed keyboard layouts (input methods)

So the first option—US (Customized)—should be the default option. The advanced settings dialog confirms this as well as shows the layouts in the same order:

Keyboard Advanced settings in Windows Server 2012

Also, the keyboard layout switching pop-up shows US (Customized) at the top and Czech (Customized) below.

However, when login into the system, the second, or maybe last one, is selected by default, i.e. the Czech (Customized) option. Is this a bug in the OS or am I missing something? Note that I experience the same behavior when I copy the input methods to the login screen settings—when logging-in, the default isn't the first on the list.

So how does the auto-selection of the default keyboard layout really work in Windows 8 and Windows Server 2012, when there's no override in place in the advanced settings?

share|improve this question
2  
I have the same problem and I almost never login myself on the first try. There should be some option for the login screen to always use the default language. –  Juraj Suchár Oct 31 '12 at 5:38
1  
@OliverSalzburg What's the reason for removing the keyboard-layout tag? –  Ondrej Tucny Apr 28 at 20:53
1  
@OliverSalzburg I believe a windows-8 and keyboard-layout tags applied together do make for the necessary distinction. At least we use tags this way on Stack Overflow. –  Ondrej Tucny Apr 28 at 21:05
1  
@OliverSalzburg That just doesn't make sense. windows-8 alone does not make sense because it can easily account for 10 % of SuperUser's content. Will ask about it on Meta. –  Ondrej Tucny Apr 28 at 21:15
1  
@OndrejTucny You are 100% right and the guy who removed the tag is 100% wrong. "We generally don't like tags that …" - wtf? StackOverflow and SuperUser really aren't on the same level. While the former is a great site, SU abounds with patronizing, arrogant admins à la Wikipedia who make high-handed edits to posts, delete comments, and even entire questions should the discussion in the comments threaten to expose the ignorance that underpins their purported superuser/superadmin status. Well, the name of the site is »superuser«, nomen est omen. –  Lumi May 27 at 6:40

3 Answers 3

It's not a bug, it's a feature! To set input language of the login screen open the control panel "Control Panel > Clock, Language, and Region > Language". Click at the link Advanced settings. Set the Windows display language and input method as you want it. Then click at the link Apply language settings to the welcome screen etc. Click at the button Copy settings. Click at the checkbox Copy settings to Welcome screen and system accounts. Click OK. Close all windows. Log out.

share|improve this answer
    
Thanks, this solved my problem of a VNC service using the wrong keyboard layout. –  Christian d'Heureuse Apr 15 at 14:10

In Advanced settings

  1. Change Override default input language to English
  2. Choose Let me set a different input method for each app window
  3. Reboot
share|improve this answer

Not strictly related to your question, as you specifically mention that your problem occurs on the login screen, but many others have encountered a bug in Windows 8 where the keyboard language switched at random.

Having followed the brief discussion on this forum post, it appears that if you specify the keyboard languages under separate languages, the keyboard language no longer randomly switches.

Specifically, in my scenario, I had English (United States) with a US keyboard and United States-International keyboard. I resolved my problem by removing the US International keyboard and adding Dutch as a new language with that keyboard. Win+Space still works as previously.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.