Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 Professional (UK), and trying to get filenames containing Chinese characters to display correctly in Explorer.

I can create Chinese filenames in explorer by pasting text from a webpage or using the Chinese IME to rename files, but the characters just display as boxes (Unicode 'missing character' glyph).

The Chinese fonts are installed on the system, and web pages display OK in the browser. In particular, I can see the correct Chinese filenames by pointing chrome at file://C:\, for example.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

There's a possible solution posted at How can I get Chinese/Japanese characters to display properly instead of squares?

So the trick is to change the system locale to Chinese (PRC) and then changing the system locale back to English (United States). I can now see the Simplified Chinese characters correctly in my buddyllist as well as in browser titles. I've attached a screenshot of the menus to get to the system locale. Basically go where you changed your input method and follow the screenshot below:

http://www.twitpic.com/18uhgc

share|improve this answer
    
Thanks. Looks like I wasn't going mad ;-) –  Roddy Sep 26 '12 at 21:17

Here's the solution I found, but it seems wholly bizarre. I'd welcome comments or confirmation that this works for others...

Step 1: Go to Control Panel/Region and Language/Administrative and select "Change System Locale". Select one of the Chinese options.

Region and Language screenshot

Step 2: Reboot. You should now see Chinese file and folder names correctly.

This is odd enough, as surely Explorer is a Unicode application, so shouldn't be affected.

Step 3: Go back to the previous dialog, and reset the Locale to English, or whatever you had before.

Step 4: Reboot.

To my surprise, after step 4, Explorer still shows Chinese names correctly.

enter image description here

share|improve this answer

There is another workaround:

  • go to control panel, choose "Fonts"
  • choose "Font settings"
  • uncheck "Hide fonts based on language settings"
  • reboot Windows
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.