Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently running Windows 8 (downloaded from DreamSpark) on a Macbook Pro. This worked fine for a while but suddenly all audio stopped working. When I go to "Playback devices" and hit "Test" on the speakers I get treated with the following message:

screenshot of error message

This also shows up right after I try restarting. I tried disallowing exclusive usage of the devices but it makes no difference.

Edit: After some looking around I tried changing the sample rate and bit depth so I would get a dialog screen to force Windows to go around the program that's using it. I did get the dialog but then instead of changing it I got the following error:

screenshot of error message

Edit 2: I narrowed it down to a single service failing to start, the Multimedia Class Scheduler service fails to start with the following error:

screenshot of error message

share|improve this question

3 Answers 3

Try the solutions posted by thecraigmcrae and Robin Fleming here or phyllismc's solution here. Don't know if it's the same problem, but sounds similar.

Specifically, Robin's:

Right click "Computer"
Click "Manage"
Under the "System Tools" section, Double click "Local Users and Groups"
Click "Groups"
Right click "Administrators"
Click "Add to group..."
Click "Add"
Click "Advanced"
Click "Find Now"
Double click "Local Service"
Click "Ok"
"NT Authority\Local Service" should show up in the list now
Click "Ok"
Close Computer Management and reboot.

Phyllis's:

On your Start Menu, in the StartSearch Box, type: services.msc
When the Services Window pops up, find: Windows Audio and Windows Audio Endpoint
Right click on these two services and Restart.

and

Windows Start menu, choose 'Run...'. In the pop-up box, type: regedit.
Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
Delete the registry key DefaultAccessPermission. (If it isn't there, chances are this isn't the problem causing your lack of sound.)

and Craig's:

1 Go to control panel
2. Double-Click on the Sound Icon
3. Single-click the Speakers to highlight them
4. Click on Properties (bottom right corner)
5. Go to the Enhancements Tab and Click on it
6. Now click "Disable All Sound Effects"
7. Click OK and you should be good to go!

share|improve this answer
    
First one didn't fix it. Second one doesn't apply since I restarted anyways. Third one, there is no key named that. And the last one didn't fix it either. –  Kelvin Bongers Sep 28 '12 at 8:50

I know a lot of mac users having the same problem i dont know how to fix it but if your unable to get sound working try reinstalling the mac osx and get this software called parallel windows found here this will let you run osx and windows without any problems

share|improve this answer
    
Re-installing OSX will do nothing because the problem is in windows and not in OSX and it appears to be a problem with one of the services. Also I have no need for parallels because I just dual boot windows with rEFIt. –  Kelvin Bongers Oct 2 '12 at 6:49
    
did you have sound to start with or have you never had sound when booting windows? –  Mack145 Oct 6 '12 at 15:40
up vote 0 down vote accepted

After a while suddenly a red light wend on in the headphone jack, I simply plugged in a non-optical headset and it started working again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.