Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus K55V laptop with Windows 7 Home Premium x64. Whenever I try to use a mouse (or any other USB device), it doesn't work because of a driver problem.

The automatic update tries to update the driver and requires me to reboot directly after. It doesn't work. Windows Update then wants to re-attempt the update and then I have to reboot (etc). Now, after 10 tries it still doesn't work.

No USB ports work at the moment, it has 2 USB 3.0 ports and 1 USB 2.0 port. Can someone help me out on this?

share|improve this question
    
From @leaveswater02: For the USB3.0 ports try the ASUS (asus.com/Notebooks_Ultrabooks/K55VD/HelpDesk_Download), AsMedia 3.0 Driver under the USB section and for USB 2.0 try the Intel Management Engine under the Others section. –  fixer1234 Jan 5 at 5:48

3 Answers 3

Please try to update the USB driver manually in the device manager. Assuming this is for Windows

W7 guide

Vista guide

XP guide

enter image description here

share|improve this answer
    
i tried to, but it did not give me permission for it as it seemed the latest driver already was installed, but it isnt working correctly –  Pascal Schilling Sep 27 '12 at 8:38
    
Yes, the error occurs at every USB port. –  Pascal Schilling Sep 27 '12 at 8:44
    
Windows 7 Home Premium 64 Bit –  Pascal Schilling Sep 27 '12 at 8:48
    
Please download the USB driver from support.asus.com/… and then use this driver instead of the default OS version. –  Dave Sep 27 '12 at 8:49
    
Thanks for the support, but yet again, only the USB 3.0 has updates available, which makes USB 2.0 useless? –  Pascal Schilling Sep 27 '12 at 8:59

It seems to be a very common faults with ASUS laptops and the root cause of the problem at least for newer laptops is the USB fast charge or USB Boost charge software. Uninstall that and you're all set. Hope this helped.

share|improve this answer

For the USB3.0 ports try the ASUS AsMedia 3.0 Driver under the USB section and for USB 2.0 try the Intel Management Engine under the Others section.

share|improve this answer
    
Thanks for the useful information. Unfortunately, link-only answers are discouraged. Super User compiles questions and answers for reference and if the link disappears or is unavailable, the answer has no value. Answers are expected to be self-contained and definitive, which makes it hard to answer questions like this one. Helpful suggestions can be left as comments, which you need a little more rep for. I moved the information to a comment so it doesn't disappear if the answer gets deleted. You might want to delete the answer so it doesn't get downvoted, which would eat into your rep. –  fixer1234 Jan 5 at 5:55
    
Your edit turned a link-only answer to a linkless link-only answer. The information, including the link so it makes sense, is in a comment, with credit to you. Consider deleting this answer so your rep isn't at risk from potential downvotes. –  fixer1234 Jan 7 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.