Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My network setup at home has 2 network storage devices on the network. The one is for media content on a Popcorn Hour A-110 and the other is a D-Link DNS-320 in RAID 1 configuration for business files.

When I access these network drives and right click a folder the following context menu appears for the A-110 device, but not for the D-link.

http://i.stack.imgur.com/AkXsf.jpg

I have tested this in both Windows 7 32bit and Windows Vista 64bit. In both instances the "Always available offline" option is only available for the A-110 storage device, and not for the D-link. How do I get this option for the D-link? Any advice or ideas are welcome.

share|improve this question
    
You could goto Sync center and add a new sync partnership, although that doesn't solve why the D-Link has 'Offline files' disabled. My guess is that the D-Link doesn't support 'Offline files', or the fact it's in RAID means it doesn't. –  HaydnWVN Sep 27 '12 at 10:03
1  
Thanks for suggesting that it could in fact be the D-link that does not support offline files. This lead me to the change log for the newest firmware for the D-link and it seems that this problem was fixed. Will do the firmware upgrade tonight. –  Rynardt Sep 27 '12 at 10:27
    
I'll post it as an answer so you can accept it! –  HaydnWVN Sep 27 '12 at 10:53
    
I had the same problem using Win 7 64 bit. After trying many approach, which all seem, unable to 'make file available offline' available, I nearly gave up, until I saw some network files showing that option but not others. Upon comparing, I noticed that the files with the option enabled had 'everyone' as user besides the administrator, user, guest, home group. Now on adding the 'everyone' option in the security tab in properties of the shared folder, the 'make available offline' now appeared in the right click tab. –  user243907 Aug 7 '13 at 8:29
    
My D-link had a hardware failure. After receiving a new one and doing a firmware update, the make available offline option worked again. It might have something to do with the fact that I did not add a pasword locked user profile to the network share. –  Rynardt Aug 7 '13 at 12:12
add comment

1 Answer

up vote 0 down vote accepted

You could goto Sync center and add a new sync partnership, although that doesn't solve why the D-Link has 'Offline files' disabled. My guess is that the D-Link doesn't support 'Offline files', or the fact it's in RAID means it doesn't. As you have found - updating the firmware gives it this feature.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.