Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the following commands from the manual to install GIT

$ tar -zxf git-1.7.2.2.tar.gz
$ cd git-1.7.2.2
$ make prefix=/usr/local all
$ sudo make prefix=/usr/local install

but I'm receiving the following exceptions

...
cache.h: At top level:
cache.h:746: error: expected declaration specifiers or â...â before âtime_tâ
cache.h:889: warning: âstruct timevalâ declared inside parameter list
cache.h:895: warning: âstruct timevalâ declared inside parameter list
cache.h:970: error: expected specifier-qualifier-list before âoff_tâ
cache.h:979: error: expected specifier-qualifier-list before âoff_tâ
cache.h:997: error: expected specifier-qualifier-list before âoff_tâ
cache.h:1057: error: expected declaration specifiers or â...â before âoff_tâ
cache.h:1063: error: expected declaration specifiers or â...â before âuint32_tâ
cache.h:1064: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before ânt                                                                                                                     h_packed_object_offsetâ
cache.h:1065: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âfi                                                                                                                     nd_pack_entry_oneâ
cache.h:1067: error: expected declaration specifiers or â...â before âoff_tâ
cache.h:1069: error: expected declaration specifiers or â...â before âoff_tâ
cache.h:1070: error: expected declaration specifiers or â...â before âoff_tâ
cache.h:1094: error: expected specifier-qualifier-list before âoff_tâ
cache.h:1168: error: expected â)â before â*â token
cache.h:1177: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âre                                                                                                                     ad_in_fullâ
cache.h:1178: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âwr                                                                                                                     ite_in_fullâ
cache.h:1179: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âwr                                                                                                                     ite_str_in_fullâ
cache.h:1252: error: expected declaration specifiers or â...â before âFILEâ
In file included from credential-store.c:2:
credential.h:28: error: expected declaration specifiers or â...â before âFILEâ
credential.h:29: error: expected declaration specifiers or â...â before âFILEâ
In file included from credential-store.c:4:
parse-options.h:115: error: expected specifier-qualifier-list before âintptr_tâ
credential-store.c: In function âparse_credential_fileâ:
credential-store.c:13: error: âFILEâ undeclared (first use in this function)
credential-store.c:13: error: âfhâ undeclared (first use in this function)
credential-store.c:17: warning: implicit declaration of function âfopenâ
credential-store.c:19: error: âerrnoâ undeclared (first use in this function)
credential-store.c:19: error: âENOENTâ undeclared (first use in this function)
credential-store.c:24: error: too many arguments to function âstrbuf_getlineâ
credential-store.c:24: error: âEOFâ undeclared (first use in this function)
credential-store.c:39: warning: implicit declaration of function âfcloseâ
credential-store.c: In function âprint_entryâ:
credential-store.c:44: warning: implicit declaration of function âprintfâ
credential-store.c:44: warning: incompatible implicit declaration of built-in fu                                                                                                                     nction âprintfâ
credential-store.c: In function âmainâ:
credential-store.c:132: warning: implicit declaration of function âumaskâ
credential-store.c:144: error: âstdinâ undeclared (first use in this function)
credential-store.c:144: error: too many arguments to function âcredential_readâ
credential-store.c:147: warning: implicit declaration of function âstrcmpâ

Is this because I didn't install the dependencies?

apt-get install libcurl4-gnutls-dev libexpat1-dev gettext libz-dev libssl-dev

How do I install them offline?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

To install git offline you could type sudo apt-get install git and copy the urls of the packages apt-get tries to download. Then you can download them on another PC and install the downloaded .deb-files manually either with gdebi or, if not installed, by typing dpkg -i packagename.deb.

Note that you have to install the packages in the right order to assure that every dependency is installed before the package depending on it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.