Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pc with the Gigabyte GA-8S648FX motherboard on and it has the F6 BIOS version and I am trying to update it to F8 version with no success :)

First I used the @Bios utility Gigabyte provides, but when the process starts and when I reach the part of deleting the current BIOS, my PC crashes with a blue screen and then my BIOS recovers.

Then I tried the QFlash utility in the BIOS but it only uses Floppy disks which I can't access cause I don't have a FDD ;)

Finally, I found the solution of FlashSpi.exe from a bootable usb stick which was the closest I got. I loaded the correct BIOS version in it, booted into the utility, flashed the BIOS and finished the process successfully. But when my pc restarted the BIOS was STILL the F6 version. I've repeated the process many times with no results. Why did the BIOS not change when the flashspi was telling that the update was successful?

p.s. I saw in the first screen the pc's have when they start, that it has my motherboards name and after that it has F8 ("GA-8S648FX F8")! Does this mean that the BIOS is changed? And if so, why is it still the same?

Edit: Well as it seems i did the update. I was just paying attention to the CPU-Z which showed me the original version but changed the version's date and has the updated BIOS date. ;)

share|improve this question
1  
Why is what still the same? –  David Schwartz Sep 27 '12 at 10:07
    
When in the windows, i use CPU-Z which still shows that the BIOS version is F6. –  Michael Str Sep 27 '12 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.