Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded from Slackware64 13.37 to current (pretty close to the new version 14.0 - kernel 3.2.29) and installed vmplayer 5.0.0 build-812388.

The installation of vmplayer was only possible with the --ignore-errors option, like the previous version.

But unlike the previou version (working fine), when I try to play any of my .vmx images, I always get a 'The virtual machine is busy.' error.

In the windows client directory, vmplayer creates a lck directory with a .lck lock file in there.

Removing this file doesn't solve the issue. If I don't remove this file and try to run the virtual machine again, vmplayer exits.

When running from command line, I get this:

$ vmplayer Windows_7.vmx    
Logging to /tmp/vmware-lupe/vmware-modconfig-24735.log
filename:       /lib/modules/3.2.29/misc/vmmon.ko
supported:      external
license:        GPL v2
description:    VMware Virtual Machine Monitor.
author:         VMware, Inc.
depends:       
vermagic:       3.2.29 SMP mod_unload
Aborted

The log file mentioned above:

2012-09-26T16:53:01.299Z| vthread-3| I120: Log for VMware Workstation pid=24735 version=9.0.0 build=build-812388 option=Release
2012-09-26T16:53:01.299Z| vthread-3| I120: The process is 64-bit.
2012-09-26T16:53:01.299Z| vthread-3| I120: Host codepage=ISO-8859-1 encoding=ISO-8859-1
2012-09-26T16:53:01.299Z| vthread-3| I120: Host is Linux 3.2.29 Slackware 14.0
2012-09-26T16:53:01.298Z| vthread-3| I120: Msg_Reset:
2012-09-26T16:53:01.298Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2012-09-26T16:53:01.298Z| vthread-3| I120: ----------------------------------------
2012-09-26T16:53:01.298Z| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2012-09-26T16:53:01.298Z| vthread-3| I120: Msg_Reset:
2012-09-26T16:53:01.298Z| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/home/lupe/.vmware/config": No such file or directory.
2012-09-26T16:53:01.298Z| vthread-3| I120: ----------------------------------------
2012-09-26T16:53:01.298Z| vthread-3| I120: PREF Optional preferences file not found at /home/lupe/.vmware/config. Using default values.
2012-09-26T16:53:01.299Z| vthread-3| W110: Logging to /tmp/vmware-lupe/vmware-modconfig-24735.log
2012-09-26T16:53:01.307Z| vthread-3| I120: Reading in info for the vmmon module.
2012-09-26T16:53:01.307Z| vthread-3| I120: Reading in info for the vmnet module.
2012-09-26T16:53:01.307Z| vthread-3| I120: Reading in info for the vmblock module.
2012-09-26T16:53:01.307Z| vthread-3| I120: Reading in info for the vmci module.
2012-09-26T16:53:01.307Z| vthread-3| I120: Reading in info for the vsock module.
2012-09-26T16:53:01.307Z| vthread-3| I120: Setting vsock to depend on vmci.
2012-09-26T16:53:01.307Z| vthread-3| I120: Created new pathsHash.
2012-09-26T16:53:01.307Z| vthread-3| I120: Invoking modinfo on "vmmon".
2012-09-26T16:53:01.309Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.
2012-09-26T16:53:01.309Z| vthread-3| I120: Invoking modinfo on "vmnet".
2012-09-26T16:53:01.311Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.
2012-09-26T16:53:01.311Z| vthread-3| I120: Invoking modinfo on "vmblock".
2012-09-26T16:53:01.312Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.
2012-09-26T16:53:01.312Z| vthread-3| I120: Invoking modinfo on "vmci".
2012-09-26T16:53:01.314Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.
2012-09-26T16:53:01.314Z| vthread-3| I120: Invoking modinfo on "vsock".
2012-09-26T16:53:01.315Z| vthread-3| I120: "/sbin/modinfo" exited with status 0.

It complains about a settings and a config file missing but is loading default values.

I don't see anything more that can hint me on what to do.

How can I solve this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

As someone pointed out in vmware's forum, it is necessary to manually install the modules again:

vmware-modconfig --console --install-all

This solves the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.