Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I first installed JavaHL from Macports to enable Subclipse and I had no issues.

sudo port install subversion-javahlbindings +no_bdb +universal

Then I went to install the full Subversion Client:

sudo port install subversion

and I received the following error (see below) - any idea how to correct this?

:info:configure checking dynamic linker characteristics... darwin12.2.0 dyld
:info:configure checking how to hardcode library paths into programs... immediate
:info:configure configure: building both shared and static libraries
:info:configure checking whether libtool needs -no-undefined... no
:info:configure checking whether to avoid circular linkage at all costs... no
:info:configure checking for trang... none
:info:configure checking for doxygen... none
:info:configure checking for Expat... yes
:info:configure checking for socket in -lsocket... no
:info:configure checking for availability of Berkeley DB... no
:info:configure configure: error: Berkeley DB 4.0.14 or newer wasn't found.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_subversion/subversion/work/subversion-1.7.6" && ./configure --prefix=/opt/local --with-berkeley-db=:/opt/local/include/db46:/opt/local/lib/db46:db-4.6 --with-neon=/opt/local --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config --without-apxs --mandir=\${prefix}/share/man --disable-neon-version-check --with-serf=/opt/local --with-sasl=/opt/local
:info:configure Exit code: 1
:error:configure org.macports.configure for port subversion returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for subversion: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port subversion for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_subversion/subversion/main.log
share|improve this question

migrated from stackoverflow.com Sep 27 '12 at 13:47

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Since you installed the bindings port with the no_bdb variant, try the same for the subversion client port:

sudo port clean subversion
sudo port install subversion +no_bdb
share|improve this answer

Ports can be quite unreliable, especially when you have many libs/binaries installed. I recently deleted my entire /opt/local directory and restarted with Homebrew, much more reliable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.