Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm tying "http://google.com" into the Run prompt, click OK, and nothing happens. How do I edit the default program that handles links?

I'm using Chrome, and when I browse at its settings it is marked as the default program to handle links. Should I reinstall Chrome to fix this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Have you tried Windows 7's own settings?

If you go to start there should be an option for Standard programs (below Configuration screen), there you can set Chrome to your default browser. Worked for me.

Check this link for more information

alt text

share|improve this answer
    
Thanks, this helped. I saw both "Google.Chrome" and "Google.Chrome.ron" (my username), and changed the associations to Google.Chrome.ron –  ripper234 Sep 30 '09 at 8:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.