Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the latest version of a mass storage device driver that is used for a Silicon Image 3124 RAID controller under Windows 7 64-bit. If I load this device driver whilst the system is running then I can see the attached disks just fine and they perform very well. Subsequent boots of the system always result in a hard crash with no event log entries and certainly no log files. Renaming the offending driver in a Repair Console allows the system to boot again.

Does anybody have any idea how I can diagnose what the problem is here? There's clearly something in the driver initialisation code that is failing upon boot, but without adequate logs or the ability to trace what's going on I'm a little lost. This is a hard crash, not a BSOD, so no crash file is available.

share|improve this question

2 Answers 2

You can do one of the following things.

  1. Contact your motherboard manufacturer(i am presuming you are using onboard RAID) and try for an RMA immediately.

  2. Purchase a standalone RAID controller and use those instead.

  3. Find an older firmware and flash back.

What most likely happening is that the dirty bit that is required to "power off" the controller is not being flipped correctly. A good reason for this is a corrupted CMOS. Another reason for this of course, is a cosmic ray ^_^

share|improve this answer
    
Heh, that's half the problem - the box itself is about 3 years old so returning is out of the question. I'm pretty sure the RAID controller is OK because it runs for weeks between reboots without any problems at all. Tried upgrading and downgrading the firmware to no avail. I guess it's just a buggy driver :( –  Dean Ward Sep 27 '12 at 22:52
    
I don't know, that really doesn't sound like a finished driver. Silicon image does release periodical updates for their drivers and stops support at a stable point. I wouldn't take a chance, especially if you'r running a RAID array that has parity information on it, especially if that information is dear to you. –  AlanTuring Sep 28 '12 at 1:22
up vote 0 down vote accepted

It looks like the only way around my problem seems to be to enable the device driver only once the system is started and disable it on shutdown. I can do this programmatically using a delayed automatic windows service which other services needing the disks depend upon. The service will simply call devcon to enable the device on boot and to disable it on shutdown...

Not ideal but it'll do the job I guess. If anybody has a better suggestion please post!

share|improve this answer
    
I've created a Windows service that disables the RAID device when it stops and re-enables it when it starts. This makes sure that the RAID is safely dismounted on system shutdown and mitigates the crash issues. I'm going to submit a support request to Silicon Image as well to see if they have seen the issue before... Hopefully the driver will get fixed! –  Dean Ward Sep 28 '12 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.