Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way I can change the spell-check and auto-correct Language of IE10/Windows8? It seems to want me to write Norwegian, but I usually write English...

share|improve this question

5 Answers 5

up vote 19 down vote accepted

Check the Control Panel. Which languages do you have installed? If you have only Norwegian, try adding English as well:

enter image description here

You can then switch languages from the language icon in the taskbar.

You can also press ⊞ Win+C to bring up the Charms bar, select Settings / Change PC settings / General and modify the Spelling and Language options as required:

enter image description here

BTW, here's a complete list of supported spellchecking dictionaries and language/locales in IE 10.


Update: How do you type and spell-check in one language, but use the keyboard layout of another?

The problem with switching the input language is that normally the keyboard layout also changes, which is irritating. Here's what you can do. Say you have a German keyboard layout but normally type in English (input language), and want English spell-check (proofing language) as well.

Add English to the language list and make it your primary language by moving it to the top. Now click the Options link:

enter image description here

Here under Input method you can Add an input method:

enter image description here

So now you can have English as the input/proofing language but German as the input method/keyboard layout. You can subsequently press ⊞ Win+Space to switch between available combinations:

enter image description here

share|improve this answer
1  
Not answering the question. I have a Norwegian keyboard - I want/need Norwegian input. But I want to swap between Norwegian and English spell checking when I write. That language list only swaps UI language and input language. –  thomthom Oct 31 '12 at 17:49
1  
@thomthom: Would you care to review the update and if it helps, take back your downvote? –  Karan Oct 31 '12 at 19:41
    
Ah! There! Finally! Thank you very very much! It was driving me insane. That was not an intuitive way of setting it up. UX failure I'd say. And I'll off course up vote! :) –  thomthom Oct 31 '12 at 21:02
1  
@thomthom: Thanks, and yes, they certainly could have made it much more obvious. I don't think this is that uncommon a requirement. –  Karan Oct 31 '12 at 21:34

Write something somewhere then right click on the word then spell-check options and choose the language you want if you have more than 1 on the list that opens. If not add more in the control panel. :)

share|improve this answer

I just tried typing in English on the Sami Extended Norway (ÁŠERTŦ) input and couldn't type the word "want" because I could not find a W!

Then, with my language set to English, I added the Norwegian QWERTY keyboard. Leaving my display language as English, I was able to type in English on the Norwegian QWERTY keyboard using the on-screen keyboard on my touch screen, and the spell-checker did its job correctly after I typed "bearsss" instead of "bears". So, if you have a Norwegian QWERTY keyboard, try the steps in my original answer to see if they help.

All of the keyboard languages are under input method in Windows 8. You change the keyboard language by changing the input method. Just as an example, for my regular imput method, I use the QWERTY keyboard. I use it in English. By following the steps I provided above, I add a QWERTY keyboard in Spanish, and then I am able to type ñ, ¿, and other characters that are not available in English. In Windows 8, Norwegian and Norewegian with Sami are available in QWERTY. Sami Extended Norway is available in ÁŠERTŦ.

If this is solution does not apply to your problem, I hope that at least it will help someone else.

share|improve this answer
    
Surely there must be a way to change the language of teh spell checker without changing the input language? Swapping input language just for the spellchecker is just awkward - so is typing anything at length with the on-screen keyboard. –  thomthom Oct 31 '12 at 17:56

About the input (keyboard) language, press the Windows logo key + SPACE to switch between input methods. If you want to add an input method, go to Control panel > Clock, Language, and Region - click Change input method > Language (see the screenshot in Answer 2 above) - click Options next to the language at the top of the list > Language options - click Add an input method > Select the input method that you want, such as Norwegian, and then click Add. Press the Windows logo key + SPACE to switch to Norweigian, which you can use even when your primary language is not Norwegian.

If you have a touch screen, you can use the On-Screen Keyboard in Ease of Access to type in English, Norwegian, or any other language.

share|improve this answer
1  
The thing is, I really don't want to change the input method. I have one keyboard, a Norwegian one. I just want to change the input language, so that the dumb spell-checker could actually be a bit of use. Change the method gives me a completely different keyboard layout which means most of the keys are not what the label says anymore, which makes it more or less impossible to type. Unless you have memorized the various layouts, which I most certainly have not and will not :p –  Svish Oct 24 '12 at 20:31

The answer above is missing the most important part: how do you SWITCH languages in IE. After you have installed multiple languages, when you want to switch languages you use either the language bar or the language icon in the taskbar, right by the clock. You just click it and select the right language. All you type after that will be spell checked in the new language.

share|improve this answer
1  
Yeah... problem is that switching language also switching keyboard language, unless I've missed something. Which is very annoying, since although I want to write English, I still have a Norwegian keyboard... –  Svish Oct 10 '12 at 8:06
    
Ditto - I have exactly the same problem. The language list just swps UI or input language. None of which is a good solution when you often need to swap between spell checking languages. –  thomthom Oct 31 '12 at 17:51

protected by Community Jun 23 at 15:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.