Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
I can't delete a file - even when using unlocker

Ok, so when I try to delete this from my desktop, I get this error:

Windows Explorer Error

When I click "See what's locking this" in lock hunter, I get this:

LockHunter File Info

Now, I have a drive, called G:. I only have one physical drive, and it's D:. Also, I have NO virtual drive software installed, so I have NO clue how it got there. Right-clicking on G:\ and choosing eject doesn't do anything but change the logo, it still says the file size and whatnot. Here's the picture of the "What's locking this?" of the contained file:

LockHunter Diagnostics

But when I try to delete it...

Deletion error with filelock

Both of these files don't let me delete them. I had put win8install.iso as a virtual drive a while back, but I uninstalled that software (but can reinstall it if needed)

Additionally, I previously made a post here about this, however I now have more information about this (I hadn't noticed the G:\ drive and a few other things), and wasn't sure if I should bump up such an old post by editing it or making another post. If I should have just edited the old one, please don't get mad - I didn't know. Just close this and let me know, I'll edit the old one and attach a bounty. If not, please take a look at the answers already posted there, none of them worked (sadly)

share|improve this question

marked as duplicate by harrymc, Dave, Indrek, BBlake, DragonLord Oct 2 '12 at 13:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
when you type “compmgmt.msc” into search and type it, what do you see under disk management? –  AlanTuring Sep 28 '12 at 1:38
    
@AlanTuring I see this: i.imgur.com/EAMKC.png –  Chipperyman Sep 28 '12 at 2:28
    
Have you tried deleting it while in Safe Mode? –  Karan Sep 28 '12 at 17:47
    
@Karan that doesn't work either. –  Chipperyman Sep 29 '12 at 21:27

1 Answer 1

up vote 0 down vote accepted

Maybe you can use an Ubuntu live CD, navigate to your desktop folder and then delete it?

share|improve this answer
    
I don't have an Ubuntu live CD. I've never installed Ubuntu on this machine. –  Chipperyman Sep 28 '12 at 0:34
    
Well, the whole point of a LiveCD is that you run it from the CD. No need to install anything. If you do not like Ubuntu you could use ERD commander (a windows based liveCD). –  Hennes Sep 28 '12 at 4:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.