Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a non-interactive way to disable line wrapping in gedit? i.e., a config file? I am teaching a class and would like to change the settings for the whole class globally.

(follow-up to how to turn off line wrap in gedit?)

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Older gEdit used config files (%gconf.xml) in the hidden dirs under your ~home . The new gEdit (v. 3.**) uses dconf/gsettings backend and as such it no longer uses config files to load the editor prefs. You can either use dconf-editor or gsettings (CLI) to change gEdit preferences.
In your case, to disable line-wrap either open a terminal and run:

gsettings set org.gnome.gedit.preferences.editor wrap-mode none

or fire-up dconf-editor and navigate to org > gnome > gedit > preferences > editor and in the right pane you will see the key wrap-mode (should be the last one). Click'n'hold on its value to change it to 'none' (or GTK_WRAP_NONE on some systems).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.