Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried to reformat on Ubuntu using gparted, in Windows using their tool, and OSX using Disk Utility. I have also attempted by using the terminal but also failed there.

When I verify disk using Disk Utility, I get the following output:

Verifying volume “REDSTRIPE”    
** /dev/disk2s1    
** Phase 1 - Preparing FAT    
** Phase 2 - Checking Directories    
** Phase 3 - Checking for Orphan Clusters    
168 files, 4507316 KiB free (1126829 clusters)    

Error: This disk needs to be repaired. Click Repair Disk.

But I am unable to repair disk.

See OSX examples below:

enter image description here enter image description here

share|improve this question
What happens when you try? How do you know it failed? – John Sep 28 '12 at 4:18
I am unable to do anything in disk utility: – slowBear Sep 28 '12 at 4:24
Tell what kind of flash drive it is. – cutrightjm Sep 28 '12 at 18:16
The device is a SanDisk 8GB Flash drive. I cannot see any switches that would make this read only. – slowBear Sep 30 '12 at 21:09

The diskUtil2.png screen shot says "Writable: No". Some flash USB drives (and maybe all SDHC cards) have a tiny switch on them that allows and disallows writing and may inadvertently get thrown to "read only". Since the switch is small, it is easy to overlook. Since external hard drives don't have such switches, it's easy to forget. I had this happen to me last week with a SDHC card and it drove me bonkers for a couple of minutes until I actually slowed myself down and took the time to look at the card.

share|improve this answer
I looked for quite some time for this switch when it first happened and was unable to locate any such switch :/ – slowBear Sep 30 '12 at 21:09

Today I tried a "hardware" fix, in the line of answer 1 above: I pulled out my SDHC card, switched the tag disabling writing, switched it back to writable trying to push it all the way. It worked, before was only read on my Mac, and now it's read and write, with no other fix. Just as if the memory card needed to be reset, manually. I just hope this is the ultimate solution to the problem, and will help other users as well.

I don't have Microsoft to test weather this can happen on other platform, but I've tested cards and pen drives. Sometimes the fix was done with Check Disk, some others by unmounting it, mounting it on another Mac (a friend's one), unmounting it and remounting it back to mine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .