Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect to a VPN Server (BestUKVPN) but im failing each time I try. I get the 691 error but the username and password are OK.
I searched and I am told that the port 1723 or GRE protocol port 47 being blocked can cause this issue as well.
So How can i check them, And in case they are blocked, Unblock them?

share|improve this question
    
This might help- netstat in cmd gives the status of ports. Have a look at this support.microsoft.com/kb/308127. –  Lamb Sep 28 '12 at 17:51
    
You ISP may not be allowing them, call and ask them if they are. :) –  Ƭᴇcʜιᴇ007 Sep 28 '12 at 17:54
    
@techie007:I can easily connect from a Windows Xp machine,If it were the ISP, i shouldn't have been able to connect using windows xp! –  Hossein Sep 29 '12 at 12:41

2 Answers 2

up vote 1 down vote accepted
netstat | find "1723"

Thats all u need.

Oh and to unblock them, this page may help

http://www.manageengine.com/products/desktop-central/help/computer_configuration/configuring_windows_xp_firewall.html

share|improve this answer
    
That command didnt find anything! –  Hossein Sep 29 '12 at 12:45
    
That just means 1723 isn't currently in use. That's all. If you try netstat only, that will give you a list of all the currently used ports. The piping to find 1723 wont give you any result if your port isn't even used. –  Gutsygibbon Oct 1 '12 at 15:21
1  
A couple things to point out. 1723 TCP Microsoft Point-to-Point Tunneling Protocol (PPTP) This works in conjunction with your GRE port 47. It should be active no matter what. Also try the following: 1) Make sure the Include Windows logon domain check box is unchecked in the Options tab of the dial-up connection's Properties dialog box. 2) Make sure the dial-up connection's security option is correctly configured to use the Require secured password setting. 3) Delete all of the *.pwl files and reboot if you are using win9x. 4) Try another logon ID. –  Gutsygibbon Oct 1 '12 at 15:35
    
Well i tried running the vpn connection, and checking the netstat results,thats why i said nothing showed up.When a VPN connection is dialing, it should use that port right?when it fails then it means that port is blocked right? –  Hossein Oct 3 '12 at 9:36
1  
When the connection is dialing, the PORT HAS TO BE USED. Correct. It's not necessarily blocked but can also be disabled.(as in the service was disabled) Check the running services and see if PPTP is actually running. –  Gutsygibbon Oct 3 '12 at 16:06

GRE is a protocol, not a port. (A lot of people say "My router isn't blocking any ports" but that's irrelevant.) Your router needs to understand how that protocol works. In particular, assuming that you're using NAT (Network Address Translation), the router will need to replace your private IP address with its public IP address in the outbound packets, then do the reverse on the inbound packets. If your router doesn't understand GRE then you either need to upgrade the firmware or replace the hardware - you'll need to check the manufacturer's documentation.

You could also try a different type of VPN connection. PPTP uses GRE, but L2TP/IPSec and SSTP don't. However, the VPN server will need to support them, and it will need a digital certificate; you will also need a certificate on your computer for L2TP/IPSec. It looks as if "BestUKVPN" only support PPTP, so you'll need to decide whether it's more work to change your router or your server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.