Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Where is “Browse in same window” in Windows 7

I am trying to open an Excel file from web based email, and the file keeps opening in a new window of Internet Explorer, instead of the full Excel program. I would prefer not to download the file by clicking save (right now the download prompt is set to open automatically), and simply click the link and have it open in the full Excel program.

I also cannot install anything on this box. A reg key would be super handy too.

How can I stop this behavior in Windows 7?

share|improve this question

marked as duplicate by CharlieRB, BBlake, Indrek, techie007, Tanner Sep 29 '12 at 13:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You sure it's not your webmail service trying to be helpful by providing a viewer for people who don't have Excel? –  techie007 Sep 28 '12 at 18:05
    
@techie007 Lotus iNotes rarely does anything helpful, but yes I'm sure. It is opening Excel inside of Internet Explorer. –  Tanner Sep 28 '12 at 18:09
    
is there not an option in lotus notes as to extensions and what to do with them? –  David McGowan Sep 28 '12 at 18:23
    
@David McGowan Lotes Notes isn't even aware of the file. I get a download prompt, and when I click open it opens in IE. –  Tanner Sep 28 '12 at 18:31
    
Please check if local excel file also opens in IE ? (had to ask...) –  Lamb Sep 28 '12 at 19:26
show 1 more comment

1 Answer

up vote 0 down vote accepted

CharlieRB found a duplicate to this that showed up in none of my searches, so I'll leave this here in case this searches better.

A link within the question to a Microsoft article solved the problem by adding the following registry keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.RTF.8]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.12]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.DocumentMacroEnabled.12]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetMacroEnabled.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetBinaryMacroEnabled.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.8]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.ShowMacroEnabled.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.8]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShowMacroEnabled.12]
"BrowserFlags"=dword:800000A0

This should take care of more than just Excel.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.