Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a few images in a directory and I can only use the Terminal

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Try this:

gconftool-2 -t str -s /desktop/gnome/background /where/is/your/image/linux_12.jpg

share|improve this answer
    
For screensaver, I used $gconftool-2 --direct --config-schema xml:readwrite:/etc/gnconf.xml.mandatory --type boolean --set /apps/gnome-screensaver/lock_enabled true I get the following error: Error setting value: Can't overwrite existing read-only value: Value for '/apps/gnome-screensaver/lock_enabled' set in a read-only source at the fron of your configuration path Any idea on how to solve this? chmod didn't work –  Wasi Oct 2 '12 at 14:16
    
@Wasi did you try with sudo? (I have to ask) –  poz2k4444 Oct 2 '12 at 14:28
    
I did. Same error –  Wasi Oct 2 '12 at 17:09
    
@Wasi what permission does it have?? I mean more accurately, does it have sticky bit? –  poz2k4444 Oct 2 '12 at 23:48
add comment

I am not sure what version of GNOME you are using. Assuming you are using one of the later versions of GNOME, you can try this command to change the background:

gsettings set org.gnome.desktop.background picture-uri file:///path/to/your/image.png

Change the path to the file and the wallpaper will be changed accordingly.

GNOME started migrating most of its settings from gconf to dconf and as such, the other answer will not work for newer versions of GNOME.

(Source)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.