Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to turn off Facebook notifications on Mac OS X Mountain Lion?

share|improve this question
1  
FYI you can turn off notifications from within Facebook by going to Notification -> Settings -> Desktop and Mobile (good for older OSX versions that don't have a Notifications Center) – Yarin Dec 19 '15 at 2:12
1  
I would add that @Yarin's answer is general, whereas the answer by Daniel Beck is specific to Mountain Lion (it does not work on El Capitan because the Notifications system preferences panel is completely different). Yarin's comment ought to be made into an answer, and should be the accepted answer. – jvriesem Dec 20 '15 at 17:53

Open System Preferences, select the Notifications preference pane at the top right, and disable it there.

Screenshot

share|improve this answer
    
lol wow i don't have a notifications center on my macbook pro, its running 10.7 too...where did you get that from? – AlanTuring Sep 28 '12 at 22:06
    
@AlanTuring This question is about Mountain Lion, i.e. 10.8. – Daniel Beck Sep 28 '12 at 22:22
    
well i'm blind lol damn. – AlanTuring Sep 28 '12 at 22:29
    
Just for a reference, a solution (for El Capitan). If you click on the padlock in the address bar next to facebook.com, you can change the permissions of the site quickly. n.b you can change any permissions of a site even if its not a padlock, just click on the icon to the left of the address. – Matt Le Fleur Jan 5 at 8:47

If the above answer didn't work for you because Facebook was already disabled in System Preferences and you use Google Chrome, you may be mistaking Chrome's notifications as OS X notifications. You can disable Google Chrome Notifications by following the instructions here

  1. In the upper right corner of the browser window, click the Chrome menu.
  2. Click Settings > Show advanced settings.
  3. In the "Privacy" section, click Content settings.
  4. In the dialog that appears, go to "Notifications" and configure your desired settings
share|improve this answer
    
Thank you! I was mystified by this and didn't realize it could have been Chrome. – nyarasha Jan 6 at 16:49
    
Turning off OS X notification for FB was obvious but this finally solved my problem. – Joe Huang Jan 14 at 0:58
    
Thanks Cory. Any knows of an equivalent solution for Firefox? – Josh Jan 14 at 13:46

Option+Click the Notification Center menu bar icon, it will turn grey when disabled To re-enable Notifications, just option+click the menu bar icon again. It will turn black to signify that it’s active again.

If you’re less of a keyboard fan and more of a gestures person, you can also hush notifications directly from the panel itself.

share|improve this answer
1  
The question was not about how to turn off all notifications. – frandroid Aug 5 '14 at 15:19
    
@frandroid: Agreed (+1)...though it does get the job done.... ;-) – jvriesem Dec 20 '15 at 17:47

For El-Capitan:

press Ctrl+Space, type "Notifications", choose "Facebook"

Just select the top-left icon "None" instead of "Banners" or "Alerts"

notification settings

share|improve this answer

You must log in to answer this question.

protected by Community Jan 17 '13 at 22:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .