Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something or someone had recently deleted 90% of the files on the network. The recovery was done by copying backup files from a Linux based NAS (Baffalo Terastation Pro) back into the win2k8 servers.

After the copy, I have 100++ files that gives the following error:

http://static.spiceworks.com/attachments/post/0007/5057/SecPerm.jpg

that is what appears even when accessing as domain\administrator on a windows 7 client machine. I have read information from various places such as this, but they are all looking to delete the file. In my case, I want to recover that file.

Clearly, the file is there on the server because it contributes to file item count and folder size. It is visually there in the folder as well. But when performing any action on it e.g. moving, opening, setting security information, windows reports "specified file not found".

I have tried using the property dialog, cmd prompt takeown and icacls. All give file not found error.

Is there any way I can fix this?

share|improve this question
    
At the very least, I would expect to be able to use FTP to connect to the NAS and copy the files that way. –  RedGrittyBrick Sep 28 '12 at 22:46
    
They are not in the NAS... not sure why. But one thing is for sure, the file cannot be copied to anywhere as it will generate the "file not found" error. The file might be a new file added after the mass copy-from-NAS. –  Jake Sep 28 '12 at 22:52
    
Have you tried a chkdsk? –  Ƭᴇcʜιᴇ007 Sep 28 '12 at 23:12
    
I ran chkdsk and then rebooted. Windows renamed the corrupt file, and then I was able to delete it. –  JohnB Nov 23 '13 at 8:50
add comment

4 Answers 4

It's possible you may be able to access the file from cmd.exe using the 8.3 name.

  1. Open up cmd.exe.
  2. cd to the location of the file.
  3. Type dir /x.
  4. Use the 8.3 name (e.g., FILENA~1.txt) to copy or rename the file.
share|improve this answer
    
Nope not working. I used 8.3 names for the whole file path including the current directory at the command prompt. –  Jake Sep 28 '12 at 23:36
    
Okay. Sorry that didn't work. Then my suspicion is that the ACL (stored as a big binary blob) is garbled. It's possible (but no guarantee!) that the chown utility in Hamilton C shell may be able to remove the ACL with the -R option. Run it elevated with sudo as sudo chown -R file or as the elevated admin as su -e Administrator chown -R file. Use the free version at hamiltonlabs.com/Demo.htm. (I'm the author but not to worry that I'm trying to spam: If this doesn't work, I'll delete the comment.) –  Nicole Hamilton Sep 28 '12 at 23:54
    
Thanks nicole, but managed to solve it using another method so didn't get a chance to use your software. –  Jake Sep 30 '12 at 10:35
add comment
up vote 0 down vote accepted

Was able to bring the server down this weekend and try out some of the suggestions we got so far.

@techie007 We did the chkdisk first, there wasn't any errors then,

We boot into safemode on the server itself and was able to takeownship directly on the affected files and folders. That solved the problem.

Again, i think this is something that should have been in a KB or something than having us to trial and error.

share|improve this answer
add comment

I had issues where the files were offline with conflicts. If you are using offline files try to clear the conflicts

share|improve this answer
add comment

I had the same problem when I copied a file from linux to Windows 7. I solved it by changing the file permission on linux as:

sudo chmod 777 filename

and then copied it to Windows 7 and it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.