Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Something or someone had recently deleted 90% of the files on the network. The recovery was done by copying backup files from a Linux based NAS (Baffalo Terastation Pro) back into the win2k8 servers.

After the copy, I have 100++ files that gives the following error:

that is what appears even when accessing as domain\administrator on a windows 7 client machine. I have read information from various places such as this, but they are all looking to delete the file. In my case, I want to recover that file.

Clearly, the file is there on the server because it contributes to file item count and folder size. It is visually there in the folder as well. But when performing any action on it e.g. moving, opening, setting security information, windows reports "specified file not found".

I have tried using the property dialog, cmd prompt takeown and icacls. All give file not found error.

Is there any way I can fix this?

share|improve this question
At the very least, I would expect to be able to use FTP to connect to the NAS and copy the files that way. – RedGrittyBrick Sep 28 '12 at 22:46
They are not in the NAS... not sure why. But one thing is for sure, the file cannot be copied to anywhere as it will generate the "file not found" error. The file might be a new file added after the mass copy-from-NAS. – Jake Sep 28 '12 at 22:52
Have you tried a chkdsk? – Ƭᴇcʜιᴇ007 Sep 28 '12 at 23:12
I ran chkdsk and then rebooted. Windows renamed the corrupt file, and then I was able to delete it. – JohnB Nov 23 '13 at 8:50

I had the same problem when I copied a file from linux to Windows 7. I solved it by changing the file permission on linux as:

sudo chmod 777 filename

and then copied it to Windows 7 and it worked.

share|improve this answer
chmod followed by rmdir, in a CygWin terminal, resolved this for me. The files also had a hidden trailing space in their names. – Brock Adams Mar 21 '15 at 5:48

It's possible you may be able to access the file from cmd.exe using the 8.3 name.

  1. Open up cmd.exe.
  2. cd to the location of the file.
  3. Type dir /x.
  4. Use the 8.3 name (e.g., FILENA~1.txt) to copy or rename the file.
share|improve this answer
Nope not working. I used 8.3 names for the whole file path including the current directory at the command prompt. – Jake Sep 28 '12 at 23:36
Okay. Sorry that didn't work. Then my suspicion is that the ACL (stored as a big binary blob) is garbled. It's possible (but no guarantee!) that the chown utility in Hamilton C shell may be able to remove the ACL with the -R option. Run it elevated with sudo as sudo chown -R file or as the elevated admin as su -e Administrator chown -R file. Use the free version at (I'm the author but not to worry that I'm trying to spam: If this doesn't work, I'll delete the comment.) – Nicole Hamilton Sep 28 '12 at 23:54
Thanks nicole, but managed to solve it using another method so didn't get a chance to use your software. – Jake Sep 30 '12 at 10:35
up vote 0 down vote accepted

Was able to bring the server down this weekend and try out some of the suggestions we got so far.

@techie007 We did the chkdisk first, there wasn't any errors then,

We boot into safemode on the server itself and was able to takeownship directly on the affected files and folders. That solved the problem.

Again, i think this is something that should have been in a KB or something than having us to trial and error.

share|improve this answer

I had issues where the files were offline with conflicts. If you are using offline files try to clear the conflicts

share|improve this answer

Install UNLOCKER scann the file & delete it with unlocker (lower left corner "No Action")

share|improve this answer

This is not a rights issue and can most likely be attributed to the UAC protection.

Referring to the UAC off solution listed in this question same question on TechNet,
you could try accessing after turning of UAC but I advice against it.

I had the same error when I accidentally dropped a folder in the WindowsApps directory in the root of the secondary drive. When I tried to access it through command prompt - it would throw Bad data. Also dir /q would show 'three dots' : ... for the owner.

I rebooted the computer into command prompt (Shift + Restart > Command prompt) and was able to access and move the directory out of the protected drive. I was then able to access it normally inside windows.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .