Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to change the MAC address for the interface en1.

ifcongig

Output:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 ::1 prefixlen 128 
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 48:4b:29:36:4f:79 
    inet6 fe80::4a5b:39ff:fe46:5f89%en0 prefixlen 64 scopeid 0x4 
    media: autoselect (<unknown type>)
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 1c:3b:d6:d6:3a:25 
    inet6 fe80::1e4b:d6ff:fed6:4a26%en1 prefixlen 64 scopeid 0x5 
    inet 192.168.1.105 netmask 0xffffff00 broadcast 192.168.1.255
    media: autoselect
    status: active

Entered commands:

sudo ln -s /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport /usr/bin/airport
sudo airport -z
sudo ifconfig en1 ether B2:E6:1C:0B:C7:C9
sudo ifconfig en1 lladdr B2:E6:1C:0B:C7:C9
sudo ifconfig en1 down
sudo ifconfig en1 up
ifcongig

Output:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 ::1 prefixlen 128 
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 48:4b:29:36:4f:79 
    inet6 fe80::4a5b:39ff:fe46:5f89%en0 prefixlen 64 scopeid 0x4 
    media: autoselect (<unknown type>)
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether b2:e6:1c:0b:c7:c9 
    media: autoselect (<unknown type>)
    status: inactive

It can be seen that the address has changed. But if you go to "System Preferences / Network / Wi-Fi / Advanced / Hardware" there appears an old MAC address 1c:3b:d6:d6:3a:25. And also enabled on the router Wireless MAC Filter is not allow to go network with the old address. Which means that the address is not changed. Any solution?

share|improve this question

1 Answer 1

Try

sudo airport --disassociate
sudo ifconfig en1 down
sudo ifconfig en1 ether B2:E6:1C:0B:C7:C9
sudo ifconfig en1 up
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.