Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With Windows 7, if you have multiple accounts (and there are no passwords on those accounts), Windows will give you a welcome screen on boot to let you choose which one to log in.

With Windows 8, it will just log you straight in to the last logged in account. How can I make it act like Windows 7?

share|improve this question
    
I tried Autologin from Sysinternal too. Doesn't work. –  Felix Sep 30 '12 at 9:55
add comment

10 Answers 10

But I worked out how to fix this with out causing any other issues. This is what I did.

  1. Backup/export HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch
  2. Change the UserSwitch Enable value to 1
  3. F5 to refresh registry, then delete the UserSwitch Key
  4. From the Parent Key 'LogonUI', right-click it and select Permissions
  5. [Disable Inheritence] and select 'Remove'
  6. Now edit each User, Advanced Permissions and uncheck/untick 'Create Subkey' (This stops the key being recreated).

Reboot to test.

If there is an issue you can just merge the Userswitch.reg file you backed up and then re-edit 'LogonUI' key and check create subkey. But I haven't had any issues at all with this method. Works in Windows 8 and 8.1, Pro and Core.

Good Luck

share|improve this answer
add comment

How to Disable automatic Last User Login and always provide Select a User to Login in Windows 8 without downloading software or using any autorun scripts.

  1. open command prompt and enter/run netplwiz
  2. make sure the "Users must enter a user name and password to use this computer" has a check mark. If not put a check mark in the box and hit apply
  3. in command prompt enter/run regedit
  4. goto: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch
  5. on the right side select the "Enabled" in the list and change the value data to 1 and then click OK
  6. right click on the "UserSwitch" on the left side and select "permissions"
  7. click on Advanced button
  8. in the Permission entries list highlight the one named "SYSTEM"
  9. select "Convert inherited permissions into explicit permissions on this object"
  10. now double click on each Permission entries one at a time and un check "Full Control" and then click OK. You will not be able to do this for "Authenticated Users" and that is ok
  11. All permission entries should now be listed as "Read" under the Access category except the Authenticated Users
  12. click Apply
  13. click OK
  14. click OK
  15. restart Windows 8 and your done !
share|improve this answer
    
please provide the source of your information. –  Lorenzo Von Matterhorn Sep 26 '13 at 18:26
add comment

found this somewhere else hope it helps::Go to Control Panel > Personalization > Screen Saver and un-check On resume, display logon screen .

share|improve this answer
    
That just deals with being awoken from the screensaver, not from a Shutdown/Restart call. –  Kruug May 28 '13 at 23:01
add comment

There is a DWORD key in the registry to set this, it worked perfectly for me: I have two users with no password, Lock Screen is disabled. Upon restart it doesn't auto-logon (that's what I wanted...) check it out: How to prevent Windows 8 from automatically logging in the last user

Also, you need to prevent Windows 8 to reset the key to 0 at every restart, this is how: Help with multiple users login screen!

share|improve this answer
2  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  slhck May 19 '13 at 14:44
add comment

Tak a look here: How to disable the Windows 8 lock screen, without disabling the password?

It is probably the best solution (same as in W7). It disables both the lock screen and auto-login of accounts without password.

share|improve this answer
add comment

The only way to make it work is to set a password on all the accounts. You can choose a normal or picture password which may help the transition.

I have looked for a long time on this and went through many articles on how to bypass the lock screen hoping it would lead me to a way, as I could find only a few articles on forcing the lock screen none of which worked. But there is not. Windows attempts to bring up the last logged in account. If that account doesn't have a password it will log it in. So, if you have multiple users and you do not want them to login automatically then they have to set a password.

I don't like the answer either, but it is true. I have 4 users, (wife, 2 kids and myself). I set a password on mine, but the others do not.

A waste of time since the other 3 are locked down and can't do anything. It is like asking for a password at a kiosk.

share|improve this answer
    
I did find a way by enabling "Do not display last user name". See my answer below. –  Felix Nov 27 '12 at 0:41
add comment
up vote 6 down vote accepted

I got it working, but in an less than perfect way. This way Windows would ask you to type the username every time. Would still like it to show a welcome screen with icons you can click on every boot though.

Run secpol.msc > Local Policies > Security Options > Interactive logon: Do not display last user name > Enabled

share|improve this answer
    
secpol.msc doesn't appear to be available on Windows 8 Home. –  jmort253 Jun 23 '13 at 23:54
    
So know it does not log automatically but you will need to type in the username to log in, so it does not show the icons like in Windows 7 ? –  Devid Dec 22 '13 at 13:10
add comment

Felix, please try Logonexpert autologon tool, it should work (declared Win8 compatibility)

share|improve this answer
1  
While this may technically answer the question, it would be more helpful if you added more information about the website you've linked to. –  user3463 Oct 12 '12 at 19:05
    
I tried disabling autologon using Logonexpert, but it doesn't work either. –  Felix Oct 20 '12 at 2:34
add comment

Shutdown in W8 is not really a full shutdown, its a form of hibernation...make a command shortcut to do a full shutdown should solve it...

Open notepad and copy this into it

shutdown /s /t 0

you can change the zero to 5 if you want a 5 second delay after you launch the command, zero is immediate shutdown.

save it to your desktop as "Windows full shutdown.cmd" (change the file extension from txt to cmd)

Use this command shortcut to shutdown the PC, hopefully this will allow you to pick a user on next boot.

share|improve this answer
    
Doesn't work, it still does the auto logon. –  Felix Sep 30 '12 at 6:05
add comment

You can enable/disable autologon by clicking windows key and R to open Run dialog, or just type in the search bar netplwiz and on the User accounts panel check the mark by Users must enter a user name and password to use this computer

share|improve this answer
    
That's the first place I checked. It is checked. –  Felix Sep 29 '12 at 10:53
    
Try signing out before you shutdown windows, or put some password on your account, it seems that if there is no password on the account and the computer was shutdown with user logged it logs on automatically to that user. There should probably be some registry tweak, but I'm not able to find it –  Alen Sep 29 '12 at 11:06
    
Signing out before shutting down doesn't change it. It still logs in automatically. –  Felix Sep 29 '12 at 11:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.