Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed sshfs and tried to test it out:

sudo apt-get install sshfs
mkdir ~/foo
ssh $server_IP mkdir ~/foo
sshfs $server_IP:~/foo ~/foo

Immediately, I get $server_IP:~/foo: No such file or directory. Am I doing something wrong?

share|improve this question
    
Are your home directories on both machines at the same location? In the 3rd command, ~/foo was expanded client-side before sending the command over SSH. In the 4th command, it's either expanded server-side, or not expanded at all. Try just $server_IP:foo. – grawity Sep 29 '12 at 12:41
    
Argh! I forgot about that. They are the same. It worked with all absolute paths, though. One of the tildes must not have been expanded… – Blacklight Shining Sep 29 '12 at 13:38
    
I guess I'll just have to think of it like encfs (and other FUSE filesystems?): Always use absolute paths. – Blacklight Shining Sep 29 '12 at 13:48
    
@grawity You can make your comment into an answer; it solved my problem. – Blacklight Shining Nov 11 '12 at 7:38
    
I always wonder...why does sshfs require absolute path? With any other ssh-supported programs, like scp, rsync, ~ expansion has always been assumed. So far, I find sshfs as the only exception – Antony Jan 8 '13 at 15:06

You must log in to answer this question.

Browse other questions tagged .