Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

By default in Windows 8 when you are listening to a song and switch to Desktop or any other app that takes full screen then the Music Player app sound level fades. Of course I can dock the app on the side but then it takes desktop space.

How can it be made to not fade the music level when in background?

EDIT This question is about Metro UI music player, not WMP.

share|improve this question
    
Use a different media player like VLC. –  Zuck Oct 28 '12 at 14:53
    
WMP is a desktop app. I can't reproduce the behavior –  Louis Oct 28 '12 at 18:40
1  
@Louis: there are two versions. I can't reproduce this behavior. Using either version does not fade anything. –  houbysoft Oct 28 '12 at 20:13
    
Can you look in the settings of both the Modern UI WMP and you Sound? –  Tom Wijsman Oct 29 '12 at 11:50
1  
I have the same problem using the Xbox Music App. Interestingly it only occurs sometimes... I think this has something to do with other apps trying to access the audio device as well. –  flooooo Nov 6 '12 at 14:15
show 1 more comment

4 Answers

up vote 7 down vote accepted

Here's a Technet thread which has some solutions for the same problem.

Do check out if it helps.

One of the proposed answers contains the solution to this problem:

I had this problem with Steam and something else in Windows 7. Moral of the story is as follows

  1. Windows key + x

  2. control panel

  3. Hardware and sound

  4. Sound

  5. Communications

  6. Do Nothing

  7. Apply or OK

  8. Victory Achieved

Seems the communications stuff in Steam triggers windows communications fade, which defaults to 80% (sounds about right). Following the instructions above allows you to keep steam running and avoid the audio fade problem.

Link: Technet

share|improve this answer
    
looks good - I will check if it works when I'm home. –  Turowicz Nov 14 '12 at 10:56
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Canadian Luke Jun 25 '13 at 21:27
add comment

I've been experiencing the same issue; occurs only after I wake the computer from sleep and the solution has been to terminate Steam. Audio immediately returns to normal levels.

share|improve this answer
3  
+1 Closing the Steam application solved the issue for me. –  gius Mar 19 '13 at 16:24
1  
Closing Steam works. Thanks! –  zdarsky.peter Apr 1 '13 at 11:19
add comment

I think I finally have all the pieces together.

1) Steam by default has a setting which automatically detects when you speak and transmits your voice (To disable it: Go to Steam > Settings > Voice tab and select "Use a push-to-talk key to transmit voice". and then restart Steam)

2) Windows by default lowers volume of non-communication sound by 50% when it detects communication activity (see JKarthik answer how to change this behavior)

3) Metro apps completely ignore this setting when they are at the foreground as they're considered "immersive", but once they're in the background, they are no longer considered "immersive"...

Every one of these setting sounds reasonable by itself, but together they actually create quite a disastrous user experience...

share|improve this answer
add comment

I Had a similar problem in windows 7. Except for instead of in a metro app(obviously) it was music fading to a lower volume when launching a game. The solution was to go to control panel -> Sound -> Communications Tab. Under "when windows detects communications activity" select do nothing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.